summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-22 12:46:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-22 12:46:25 +0200
commit282a1aa2fac9848ac114a45ea504fe815de42615 (patch)
tree591b7dd205ed2944a0b9bd22bcd05c35fc7ab989 /dev-util/rosdep
parentx11-misc/birdtray: version bump to 1.9.0 (diff)
downloadgentoo-282a1aa2fac9848ac114a45ea504fe815de42615.tar.gz
gentoo-282a1aa2fac9848ac114a45ea504fe815de42615.tar.bz2
gentoo-282a1aa2fac9848ac114a45ea504fe815de42615.zip
dev-util/rosdep: disable tests with network sandbox
Closes: https://bugs.gentoo.org/750494 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util/rosdep')
-rw-r--r--dev-util/rosdep/rosdep-0.19.0-r1.ebuild6
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/rosdep/rosdep-0.19.0-r1.ebuild b/dev-util/rosdep/rosdep-0.19.0-r1.ebuild
index 23c874805e5c..861de0006ff1 100644
--- a/dev-util/rosdep/rosdep-0.19.0-r1.ebuild
+++ b/dev-util/rosdep/rosdep-0.19.0-r1.ebuild
@@ -46,7 +46,11 @@ BDEPEND="
PATCHES=( "${FILESDIR}/tests.patch" )
python_test() {
- env -u ROS_DISTRO nosetests --with-xunit test || die
+ if has network-sandbox ${FEATURES}; then
+ einfo "Skipping tests due to network sandbox"
+ else
+ env -u ROS_DISTRO nosetests --with-xunit test || die
+ fi
}
pkg_postrm() {
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
index 23c874805e5c..861de0006ff1 100644
--- a/dev-util/rosdep/rosdep-9999.ebuild
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -46,7 +46,11 @@ BDEPEND="
PATCHES=( "${FILESDIR}/tests.patch" )
python_test() {
- env -u ROS_DISTRO nosetests --with-xunit test || die
+ if has network-sandbox ${FEATURES}; then
+ einfo "Skipping tests due to network sandbox"
+ else
+ env -u ROS_DISTRO nosetests --with-xunit test || die
+ fi
}
pkg_postrm() {