summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-04 14:37:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-03-04 15:20:36 +0100
commite0f53993c70f81b219207dfc0d62b8e005c2e0c2 (patch)
tree0df0bf201dee5f7f9ffa002edaac6e21edb99803 /dev-util/rosinstall_generator
parentdev-util/rosinstall_generator: Remove old (diff)
downloadgentoo-e0f53993c70f81b219207dfc0d62b8e005c2e0c2.tar.gz
gentoo-e0f53993c70f81b219207dfc0d62b8e005c2e0c2.tar.bz2
gentoo-e0f53993c70f81b219207dfc0d62b8e005c2e0c2.zip
dev-util/rosinstall_generator: bump to 0.1.14; add pypy support; add src_test
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/rosinstall_generator')
-rw-r--r--dev-util/rosinstall_generator/Manifest1
-rw-r--r--dev-util/rosinstall_generator/rosinstall_generator-0.1.14.ebuild40
-rw-r--r--dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild13
3 files changed, 50 insertions, 4 deletions
diff --git a/dev-util/rosinstall_generator/Manifest b/dev-util/rosinstall_generator/Manifest
index d9365f57616b..10d7e55e31ce 100644
--- a/dev-util/rosinstall_generator/Manifest
+++ b/dev-util/rosinstall_generator/Manifest
@@ -1 +1,2 @@
DIST rosinstall_generator-0.1.13.tar.gz 11186 BLAKE2B bb6f95eba12ee6b9adfa22d46475d555aa9b3bed225e3be52a52f380bbd1ab3f86871a9a816c56c874f8545d2ef648e226ad5d8d3346444a92202865265260f1 SHA512 c8b5736066f8a42a324b2bed578e03282b6d8ae8df48fb30545617c2995ce53f35d7fea6fab3989383b958e7cb763b24deb67c5ec3496cc77f1ba51f110ab78c
+DIST rosinstall_generator-0.1.14.tar.gz 11419 BLAKE2B af9754f46589aac1e9bb265345319c4037d2b1e10ea8119859e2715b2828974bc4422cac25f84216c401f35b7cddde207e7562afb07e753328940db347b69a20 SHA512 45461917afaf93f38b118951c272ba71a408d2c276b4019739c9c8dc9407812bf166bb762910ce45cedc9b31e2796922a69681ad461c468c7ed2372a1d189904
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-0.1.14.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-0.1.14.ebuild
new file mode 100644
index 000000000000..725ccaf60ba1
--- /dev/null
+++ b/dev-util/rosinstall_generator/rosinstall_generator-0.1.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosinstall_generator"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Generates rosinstall metadata about repositories with ROS packages/stacks"
+HOMEPAGE="http://wiki.ros.org/rosinstall_generator"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosinstall_generator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
+ >=dev-python/rosdistro-0.5.0[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --with-coverage || die
+}
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
index 484e133e8ea0..725ccaf60ba1 100644
--- a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
+++ b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -24,7 +24,7 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="test"
RDEPEND="
>=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
@@ -32,4 +32,9 @@ RDEPEND="
dev-python/rospkg[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --with-coverage || die
+}