summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2015-08-20 09:58:24 +0200
committerGuilherme Amadio <amadio@gentoo.org>2015-08-20 09:58:24 +0200
commit766e0bda6a56bf346b4b94fe91e4895705ae3aed (patch)
tree756e7e6875544a9ef7ebdb45a25e2df604ae2ef1 /dev-util/rpmdevtools/rpmdevtools-8.5.ebuild
parentmedia-fonts/monoid: version bump (diff)
downloadgentoo-766e0bda6a56bf346b4b94fe91e4895705ae3aed.tar.gz
gentoo-766e0bda6a56bf346b4b94fe91e4895705ae3aed.tar.bz2
gentoo-766e0bda6a56bf346b4b94fe91e4895705ae3aed.zip
dev-util/rpmdevtools: version bump, fix bug 536972
Bug: 536972 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util/rpmdevtools/rpmdevtools-8.5.ebuild')
-rw-r--r--dev-util/rpmdevtools/rpmdevtools-8.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/rpmdevtools/rpmdevtools-8.5.ebuild b/dev-util/rpmdevtools/rpmdevtools-8.5.ebuild
new file mode 100644
index 000000000000..c570e9e7f489
--- /dev/null
+++ b/dev-util/rpmdevtools/rpmdevtools-8.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Collection of rpm packaging related utilities"
+HOMEPAGE="https://fedorahosted.org/rpmdevtools/"
+SRC_URI="https://fedorahosted.org/releases/r/p/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emacs"
+
+CDEPEND="
+ app-arch/rpm[python]
+ net-misc/curl
+ emacs? ( app-emacs/rpm-spec-mode )
+ dev-util/checkbashisms
+"
+
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ =dev-lang/python-2*
+ sys-apps/help2man
+"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's:#!/usr/bin/python:#!/usr/bin/python2:' rpmdev-rmdevelrpms.py || die
+}