summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-05-25 17:49:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-25 11:07:43 +0300
commit95b5bf83b726413ebbe2dbe5374c1f79e0526471 (patch)
tree165a8c6db5f9e9f001eb172853798c9e325e6552 /dev-util/rt-tests
parentapp-crypt/trousers: Remove old (diff)
downloadgentoo-95b5bf83b726413ebbe2dbe5374c1f79e0526471.tar.gz
gentoo-95b5bf83b726413ebbe2dbe5374c1f79e0526471.tar.bz2
gentoo-95b5bf83b726413ebbe2dbe5374c1f79e0526471.zip
dev-util/rt-tests: Allow to use different compilers
Currently CC and AR are hardcoded to gcc/ar. Allow compilation e.g. with clang. Closes: https://bugs.gentoo.org/724246 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/15962 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/rt-tests')
-rw-r--r--dev-util/rt-tests/rt-tests-1.8.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/rt-tests/rt-tests-1.8.ebuild b/dev-util/rt-tests/rt-tests-1.8.ebuild
index 994e2f56115f..f94e433d66c0 100644
--- a/dev-util/rt-tests/rt-tests-1.8.ebuild
+++ b/dev-util/rt-tests/rt-tests-1.8.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..8} )
-inherit python-single-r1
+inherit python-single-r1 toolchain-funcs
DESCRIPTION="A collection of latency testing tools for the linux(-rt) kernel"
HOMEPAGE="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/about/"
@@ -27,6 +27,10 @@ src_prepare() {
use elibc_musl && eapply "${FILESDIR}/${P}-musl.patch"
}
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)"
+}
+
src_install() {
emake prefix=/usr DESTDIR="${D}" MAN_COMPRESSION=none install
python_fix_shebang "${ED}"