summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-09 11:59:47 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-09 15:13:07 -0700
commit6456b69dbade96dc014e4eb4d7000e8012e75e6f (patch)
treeea923b40c933901b675bb1073050734c62baba79 /dev-util/rustup
parentnet-misc/dropbox: bump to 105.4.651 (diff)
downloadgentoo-6456b69dbade96dc014e4eb4d7000e8012e75e6f.tar.gz
gentoo-6456b69dbade96dc014e4eb4d7000e8012e75e6f.tar.bz2
gentoo-6456b69dbade96dc014e4eb4d7000e8012e75e6f.zip
dev-util/rustup: revbump, remove libressl, update helper script
Closes: https://bugs.gentoo.org/741450 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/rustup')
-rw-r--r--dev-util/rustup/files/symlink_rustup.sh26
-rw-r--r--dev-util/rustup/rustup-1.22.1-r1.ebuild (renamed from dev-util/rustup/rustup-1.22.1.ebuild)10
2 files changed, 22 insertions, 14 deletions
diff --git a/dev-util/rustup/files/symlink_rustup.sh b/dev-util/rustup/files/symlink_rustup.sh
index 529a71a13225..87365028843a 100644
--- a/dev-util/rustup/files/symlink_rustup.sh
+++ b/dev-util/rustup/files/symlink_rustup.sh
@@ -1,9 +1,9 @@
-#!/bin/bash
+#!@GENTOO_PORTAGE_EPREFIX@/bin/bash
set -euo pipefail
IFS=$'\n\t'
-SYMLINK_RUSTUP_VERSION="0.0.1"
+SYMLINK_RUSTUP_VERSION="0.0.2"
: "${CARGO_HOME:=${HOME}/.cargo}"
: "${RUSTUP_HOME:=${HOME}/.rustup}"
@@ -37,6 +37,7 @@ help() {
echo " ${CARGO_HOME}"
echo
echo "Options:"
+ echo " -a, --apply Apply changes (required)"
echo " -C, --nocolor Disable colored output"
echo " -d, --debug Debug mode (sets -x shell option)"
echo " -V, --version Print version number"
@@ -52,7 +53,7 @@ symlink_rustup() {
rust{c,doc,fmt,-gdb,-lldb,up}
)
- binpath="${EPREFIX:-}/usr/bin/rustup-init"
+ binpath="@GENTOO_PORTAGE_EPREFIX@/usr/bin/rustup-init"
gentoo_rust="$(eselect --brief rust show 2>/dev/null)"
mkdir -p "${CARGO_HOME}/bin" || die
@@ -62,15 +63,15 @@ symlink_rustup() {
if [[ -e "${symlink_path}" ]]; then
die "${symlink_path} ${__err_exists}"
else
- ln -sv "${binpath}" "${symlink_path}" || die
+ ln -s ${QUIET--v} "${binpath}" "${symlink_path}" || die
fi
done
good "Setting gentoo ${gentoo_rust// /} as default toolchain"
- "${CARGO_HOME}/bin/rustup" -v toolchain link gentoo "${EPREFIX:-}/usr" || die
- "${CARGO_HOME}/bin/rustup" -v default gentoo || die
- "${CARGO_HOME}/bin/rustup" -V || die
- "${CARGO_HOME}/bin/rustup" show || die
+ [[ ${QUIET+set} != set ]] && "${CARGO_HOME}/bin/rustup" -V
+ "${CARGO_HOME}/bin/rustup" ${QUIET--v} toolchain link gentoo "/usr"
+ "${CARGO_HOME}/bin/rustup" ${QUIET--v} default gentoo
+ [[ ${QUIET+set} != set ]] && "${CARGO_HOME}/bin/rustup" show
good "Prepend ${CARGO_HOME}/bin to your PATH to use rustup"
good "rustup selfupdate is disabled, it will be updated by portage"
@@ -82,6 +83,9 @@ main(){
me="$(basename "${BASH_SOURCE[${#BASH_SOURCE[@]} - 1]}")"
while [[ ${#} -gt 0 ]]; do
case ${1} in
+ -a|--apply)
+ APPLY=true
+ ;;
-h|--help)
help
exit 0
@@ -106,7 +110,11 @@ main(){
esac
shift
done
- symlink_rustup
+ if [[ ${APPLY:-false} == true ]]; then
+ symlink_rustup
+ else
+ help
+ fi
} # main()
diff --git a/dev-util/rustup/rustup-1.22.1.ebuild b/dev-util/rustup/rustup-1.22.1-r1.ebuild
index 6b91f9160037..fa40b7f00826 100644
--- a/dev-util/rustup/rustup-1.22.1.ebuild
+++ b/dev-util/rustup/rustup-1.22.1-r1.ebuild
@@ -239,7 +239,7 @@ zeroize-1.1.0
zeroize_derive-1.0.0
"
-inherit bash-completion-r1 cargo
+inherit bash-completion-r1 cargo prefix
HOME_CRATE_COMMIT="a243ee2fbee6022c57d56f5aa79aefe194eabe53"
@@ -252,13 +252,13 @@ SRC_URI="https://github.com/rust-lang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 CC0-1.0 MIT Unlicense ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
-IUSE="libressl"
+IUSE=""
+# requires old libressl-2.5, so openssl only for now.
DEPEND="
app-arch/xz-utils
net-misc/curl:=[http2,ssl]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
"
RDEPEND="${DEPEND}"
BDEPEND="virtual/rust"
@@ -283,7 +283,7 @@ src_install() {
cargo_src_install --features no-self-update
einstalldocs
exeinto /usr/share/rustup
- newexe "${FILESDIR}/symlink_rustup.sh" symlink_rustup
+ newexe "$(prefixify_ro "${FILESDIR}"/symlink_rustup.sh)" symlink_rustup
ln -s "${ED}/usr/bin/rustup-init" rustup || die
./rustup completions bash rustup > "${T}/rustup" || die