summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-09 15:11:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-09 16:30:13 +0200
commit939bc35168df5202903e0a6b89edff80f69aa15a (patch)
treef80777f6a8bf06d56b39183e7db2417bb40367af /dev-util/scons/scons-3.0.1.ebuild
parentpackage.mask: Masked >=sys-auth/polkit-0.114 (diff)
downloadgentoo-939bc35168df5202903e0a6b89edff80f69aa15a.tar.gz
gentoo-939bc35168df5202903e0a6b89edff80f69aa15a.tar.bz2
gentoo-939bc35168df5202903e0a6b89edff80f69aa15a.zip
dev-util/scons: Bump to 3.0.1
Diffstat (limited to 'dev-util/scons/scons-3.0.1.ebuild')
-rw-r--r--dev-util/scons/scons-3.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/scons/scons-3.0.1.ebuild b/dev-util/scons/scons-3.0.1.ebuild
new file mode 100644
index 000000000000..d511a65da38a
--- /dev/null
+++ b/dev-util/scons/scons-3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible Python-based build utility"
+HOMEPAGE="http://www.scons.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? (
+ http://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
+ http://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> ${P}-user.html
+ )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc"
+
+python_prepare_all() {
+ # remove half-broken, useless custom commands
+ # and fix manpage install location
+ sed -i -e '/cmdclass/,/}$/d' \
+ -e '/data_files/s:man/:share/man/:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( {CHANGES,README,RELEASE}.txt )
+ distutils-r1_python_install_all
+ rm "${ED%/}/usr/bin/scons.bat" || die
+
+ use doc && dodoc "${DISTDIR}"/${P}-user.{pdf,html}
+}