summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2019-06-08 00:45:13 +0300
committerMichał Górny <mgorny@gentoo.org>2019-06-15 16:19:18 +0200
commit533377ccb5baa6cb6e6b2055c63bfafd895b8fc2 (patch)
treecb29e8086b7834fadfacdeec09b5dc0cb6e94025 /dev-util/scons/scons-3.0.5-r1.ebuild
parentdev-util/scons: 3.0.5-r1 fix passthrough of $PATH env (diff)
downloadgentoo-533377ccb5baa6cb6e6b2055c63bfafd895b8fc2.tar.gz
gentoo-533377ccb5baa6cb6e6b2055c63bfafd895b8fc2.tar.bz2
gentoo-533377ccb5baa6cb6e6b2055c63bfafd895b8fc2.zip
dev-util/scons: fix CC, CXX, C*FLAGS, LDFLAGS tests
Unset the AR AS ASFLAGS, CC, CXX, CFLAGS, CXXFLAGS, CPPFLAGS, LDFLAGS flags within python_test() phase to ignore the "*-respect-cc-etc-r1.patch" within test env. It repairs the failures of the tests that are associated with this flags. Failures were caused by parsing error of passed values. Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/scons/scons-3.0.5-r1.ebuild')
-rw-r--r--dev-util/scons/scons-3.0.5-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-util/scons/scons-3.0.5-r1.ebuild b/dev-util/scons/scons-3.0.5-r1.ebuild
index e7f2ac66479c..d38461f93b0d 100644
--- a/dev-util/scons/scons-3.0.5-r1.ebuild
+++ b/dev-util/scons/scons-3.0.5-r1.ebuild
@@ -64,6 +64,8 @@ src_prepare() {
python_test() {
# set variable from escons() of scons-util.eclass to make env-passthrough patch work within test env
local -x GENTOO_SCONS_ENV_PASSTHROUGH=1
+ # unset some env variables to pass appropriate tests
+ unset AR AS ASFLAGS CC CXX CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
cd "${WORKDIR}/${P}" || die
"${EPYTHON}" runtest.py -a --passed \
-j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \