summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-21 14:31:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-21 14:39:37 +0200
commit01ff22d8f3a70a893c674138d9197b4057c3f644 (patch)
tree248e1a1d706a693e368b2a66e615ef93fdc6f3be /dev-util/scons
parentdev-lang/python: Bump to 3.9.0b5 (diff)
downloadgentoo-01ff22d8f3a70a893c674138d9197b4057c3f644.tar.gz
gentoo-01ff22d8f3a70a893c674138d9197b4057c3f644.tar.bz2
gentoo-01ff22d8f3a70a893c674138d9197b4057c3f644.zip
dev-util/scons: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/Manifest4
-rw-r--r--dev-util/scons/scons-4.0.1.ebuild87
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/scons/Manifest b/dev-util/scons/Manifest
index 19474baa8d4c..69386a2572a3 100644
--- a/dev-util/scons/Manifest
+++ b/dev-util/scons/Manifest
@@ -10,3 +10,7 @@ DIST scons-4.0.0-user.html 1414886 BLAKE2B 1005a79040a4e035fa667a7c2f6231300c5fc
DIST scons-4.0.0-user.pdf 2468838 BLAKE2B 6541fbc9d8f409ccde07746cb2a6e046fe4a4b868c2b6b80401c30c9d99a27acb2a4aedba9f47ba9e4cf8ac62510bec43a9aac33cba6912b837e13baeb996353 SHA512 cc62fd88dc0dda77515328b434492f8dbc0b4f615a2f3bb4841391ded7fbc738050b2ca7308c820d55efa59c28540391bd546ecec909b1fa7df66a944bdaa8aa
DIST scons-4.0.0.gh.tar.gz 5584060 BLAKE2B 316be6af0cf52181391ba3251315a0d7da6024a3c650c3de927ff9db041aba096a95f09a7a13f64f78e20473490eb08fb2b0da191c9c3957fad9113e2d3dab14 SHA512 8277c8ceeba5e9612e8c757b3ab736cf116f66e707f4127b1e09f21d3a71ca7fd13dde0453f73b97c168cd05d8ba97084c010f3dcc1e29bb26ebbbeae9ea8338
DIST scons-4.0.0.tar.gz 2874600 BLAKE2B 439b4e32cb62f5b9546af771eb292a5ff36eddb23fbd169fe065d2dbc3c3916d0551a2807bf765952384e46e036fe4b6142b739b5cfe385217539e1a22daf5ff SHA512 38c8f6600bc5f4b5385eb65ff1e98e8464dcea2a1128173f883a06822eca2e250998c666418a9cbbe2c30ff26da4de3c5fdd68381e68708d93e59bea8680337c
+DIST scons-4.0.1-user.html 1415152 BLAKE2B 1a94b2ef5e076d883f2960825f055c7cc39cfd1848be797a9519bf94834cd4174d3da3274ef77f64106c1cc182c3f8cef363e3982f5c227d3a6dcbeadbc847c2 SHA512 f1165836ad80c90caa4d936ffc86c0ed20ea4c5e7854c36fee3a2c575b1c05c731d4ece9554e43292e6da30176ad9f31f31cf12f84264307c1494f79b06f43c7
+DIST scons-4.0.1-user.pdf 2468804 BLAKE2B f0af6bc6b41d972b98e955ee3ccec908aa366eabe31bd01022abe1f6d3a94dd6d7da26f71de23a6dfbcbc7bb4e439463f69bb7e8a5780c1300e3ba508b9eb314 SHA512 0d2733e2f1391083522a64117bfd35a2160d1366382f6f630b26eba36fc12ce797467d5e16efeb3b7f58aa9d853f96ae0d50fe78f59e78d24642b146bc7e565d
+DIST scons-4.0.1.gh.tar.gz 5578800 BLAKE2B f9ece5eaf1b133219f975e484beb5df726560a38969b8e8ad829781b960b438458bfcd7971333da87560c957675b2a4f8675e757fb0a4268cc4ecf72bb60d45f SHA512 f23c5dfd3c236e9f9f85b986ca64a36dbd85e9f3383cb3577e082a7dea4b83283020fbf064c2d919ab116195c6708fc11f906fcf3b0bc0533a4bc49a4f7371c6
+DIST scons-4.0.1.tar.gz 2874481 BLAKE2B 98377e62ae31d32758a93c4e04c578b88ea541cc292af63c6ca43e2948745e416ee6d757d98129ee30d0e0bbab90664889441a5bb86d4c9dfc649ca1dbef7536 SHA512 400b11323d48f04395b519dfafb6fce15a6dea92013f599dc4895b112629c0a06c7d2806755c74047d001d60087b94f39a118f512b7ee8de6214a4ffc7310468
diff --git a/dev-util/scons/scons-4.0.1.ebuild b/dev-util/scons/scons-4.0.1.ebuild
new file mode 100644
index 000000000000..3325adc75936
--- /dev/null
+++ b/dev-util/scons/scons-4.0.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible Python-based build utility"
+HOMEPAGE="https://www.scons.org/"
+SRC_URI="
+ https://downloads.sourceforge.net/project/scons/scons/${PV}/${P}.tar.gz
+ doc? (
+ https://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
+ https://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> ${P}-user.html
+ )
+ test? ( https://github.com/scons/scons/archive/${PV}.tar.gz -> ${P}.gh.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+S=${WORKDIR}/${P}/src
+
+PATCHES=(
+ # support env passthrough for Gentoo ebuilds
+ "${FILESDIR}"/scons-4.0.0-env-passthrough.patch
+ # respect CC, CXX, C*FLAGS, LDFLAGS by default
+ "${FILESDIR}"/scons-4.0.0-respect-cc-etc-r1.patch
+)
+
+src_unpack() {
+ # use the git directory structure, but put pregenerated release
+ # inside src/ subdirectory to make our life easier
+ if use test; then
+ unpack "${P}.gh.tar.gz"
+ else
+ mkdir -p "${P}"/src || die
+ fi
+
+ tar -C "${P}"/src --strip-components=1 -xzf "${DISTDIR}/${P}.tar.gz" || die
+}
+
+src_prepare() {
+ # apply patches relatively to top directory
+ cd "${WORKDIR}/${P}" || die
+ distutils-r1_src_prepare
+
+ # remove half-broken, useless custom commands
+ # and fix manpage install location
+ sed -i -e '/cmdclass/,/},$/d' \
+ -e '/data_files/s:man/:share/man/:' "${S}"/setup.py || die
+}
+
+python_test() {
+ # set variable from escons() of scons-util.eclass to make env-passthrough patch work within test env
+ local -x GENTOO_SCONS_ENV_PASSTHROUGH=1
+ # unset some env variables to pass appropriate tests
+ unset AR AS ASFLAGS CC CXX CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
+ cd "${WORKDIR}/${P}" || die
+ "${EPYTHON}" runtest.py -a --passed \
+ -j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ --builddir "${BUILD_DIR}/lib"
+
+ # runtest.py script returns "0" if all tests are passed
+ # and returns "2" if there are any tests with "no result"
+ # (i.e. in case if some tools are not installed or it's Windows specific tests)
+ [[ ${?} == [02] ]] || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc "${DISTDIR}"/${P}-user.{pdf,html}
+}