summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-05 16:37:51 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-08 23:48:30 +0100
commite5cb93ff2e6417fcdc036c06ee385ec022d7bd7e (patch)
treec1d40f57540d24dbc8dde71d1b3151a99df2636c /dev-util/sel
parentdev-libs/http-fetcher: take over maintainership. (diff)
downloadgentoo-e5cb93ff2e6417fcdc036c06ee385ec022d7bd7e.tar.gz
gentoo-e5cb93ff2e6417fcdc036c06ee385ec022d7bd7e.tar.bz2
gentoo-e5cb93ff2e6417fcdc036c06ee385ec022d7bd7e.zip
dev-util/sel: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/sel')
-rw-r--r--dev-util/sel/sel-0.08.4-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/sel/sel-0.08.4-r2.ebuild b/dev-util/sel/sel-0.08.4-r2.ebuild
new file mode 100644
index 000000000000..d858c06807be
--- /dev/null
+++ b/dev-util/sel/sel-0.08.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A filemanager for shell scripts"
+SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
+HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+
+RDEPEND="sys-libs/ncurses:0="
+
+DOCS=( "help.txt" README.GER whatsnew )
+
+src_prepare () {
+ default
+ sed -i \
+ -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
+ "${PN}.c" || die 'sed failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
+}
+
+src_install () {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}