summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-09 17:20:02 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-09 17:22:54 +0100
commitf2cc6de11561bcb15fe0a2654a9193b85434b48f (patch)
tree56eabc0531111e4d78fcb4e47eb0b3ec2d41e8e8 /dev-util/sel
parentdev-lua/luacheck: Stabilize 0.23.0-r1 ppc, #764617 (diff)
downloadgentoo-f2cc6de11561bcb15fe0a2654a9193b85434b48f.tar.gz
gentoo-f2cc6de11561bcb15fe0a2654a9193b85434b48f.tar.bz2
gentoo-f2cc6de11561bcb15fe0a2654a9193b85434b48f.zip
dev-util/sel: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/691306 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/sel')
-rw-r--r--dev-util/sel/sel-0.08.4-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-util/sel/sel-0.08.4-r2.ebuild b/dev-util/sel/sel-0.08.4-r2.ebuild
index 6c4bae9142a8..c301ba522d1b 100644
--- a/dev-util/sel/sel-0.08.4-r2.ebuild
+++ b/dev-util/sel/sel-0.08.4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ppc s390 sparc x86"
RDEPEND="sys-libs/ncurses:0="
+BDEPEND="virtual/pkgconfig"
DOCS=( "help.txt" README.GER whatsnew )
@@ -25,7 +26,8 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="$(${PKGCONFIG} --libs ncurses)"
}
src_install() {