summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-09-21 22:08:41 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-22 23:05:08 +0200
commitbd31a6ae538a52b899d9324fc8d6767ae0c42673 (patch)
tree9cf17544db7efb60b0a496a0fa38ffa9e8f21bba /dev-util/shflags/shflags-1.2.3.ebuild
parentapp-misc/evtest: Version bump (v1.33) (diff)
downloadgentoo-bd31a6ae538a52b899d9324fc8d6767ae0c42673.tar.gz
gentoo-bd31a6ae538a52b899d9324fc8d6767ae0c42673.tar.bz2
gentoo-bd31a6ae538a52b899d9324fc8d6767ae0c42673.zip
dev-util/shflags: version bump.
Closes: https://bugs.gentoo.org/665454 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/shflags/shflags-1.2.3.ebuild')
-rw-r--r--dev-util/shflags/shflags-1.2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/shflags/shflags-1.2.3.ebuild b/dev-util/shflags/shflags-1.2.3.ebuild
new file mode 100644
index 000000000000..0466a6600bd6
--- /dev/null
+++ b/dev-util/shflags/shflags-1.2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line flags module for Unix shell scripts"
+HOMEPAGE="https://github.com/kward/shflags"
+SRC_URI="https://github.com/kward/shflags/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+src_test() {
+ sh test_runner || die
+}
+
+src_install() {
+ dodoc README* doc/*.txt
+ insinto /usr/share/misc
+ doins "${PN}"
+ use examples && dodoc examples/*
+}