summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-08-11 05:01:44 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-08-11 05:01:54 +1000
commit44cf20d6bf920378d0e1e7a66d8e9869c99124d7 (patch)
tree26b0ee2d69e348b74798b27d0d4f1bee8b5618b6 /dev-util/shunit2
parentnet-libs/telepathy-qt: remove old (diff)
downloadgentoo-44cf20d6bf920378d0e1e7a66d8e9869c99124d7.tar.gz
gentoo-44cf20d6bf920378d0e1e7a66d8e9869c99124d7.tar.bz2
gentoo-44cf20d6bf920378d0e1e7a66d8e9869c99124d7.zip
dev-util/shunit2: revision bump with various fixes
* Port to EAPI 6 * Remove unused dependencies (there no longer is a compile phase) * Remove unused eclass inherit * Remove unused USE flags * Remove redundant die calls Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/shunit2')
-rw-r--r--dev-util/shunit2/shunit2-2.1.6-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/shunit2/shunit2-2.1.6-r1.ebuild b/dev-util/shunit2/shunit2-2.1.6-r1.ebuild
new file mode 100644
index 000000000000..22a6bf711c31
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts"
+HOMEPAGE="https://github.com/kward/shunit2"
+SRC_URI="https://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_install() {
+ dobin src/shunit2
+
+ # For backwards compat to <=2.1.5
+ dosym /usr/bin/shunit2 /usr/share/shunit2/shunit2
+
+ dodoc -r examples
+ dodoc doc/*.txt
+
+ docinto html
+ dodoc doc/*.{html,css}
+}