summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/skelgen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/skelgen')
-rw-r--r--dev-util/skelgen/Manifest1
-rw-r--r--dev-util/skelgen/files/skelgen-1.2-gcc43.patch10
-rw-r--r--dev-util/skelgen/metadata.xml7
-rw-r--r--dev-util/skelgen/skelgen-1.2.ebuild39
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/skelgen/Manifest b/dev-util/skelgen/Manifest
new file mode 100644
index 000000000000..0c067a207bc4
--- /dev/null
+++ b/dev-util/skelgen/Manifest
@@ -0,0 +1 @@
+DIST Fluid_Studios_Skeleton_Source_File_Generator-1.2.zip 218041 SHA256 6b502f4e9d171d00bc1f8f0147dd8adf75eb826a178c08bf5a5c8f7f839aff66 SHA512 7424f773cecefb9ce25712a22ba0a436f658125f2de4da55bba4717d23abea8c7ba7f7df48260dea96d40c98bb15ae6e07ffe3cb2aed4cb20603f0529cdca76b WHIRLPOOL 92851404a5487c536696e68b102dbb7f4e00f895d3300a4f7bdd76e72332f8ca75b1642ada257d807f5f0430bd2537f80fc354695c507beea4f1df06ee296419
diff --git a/dev-util/skelgen/files/skelgen-1.2-gcc43.patch b/dev-util/skelgen/files/skelgen-1.2-gcc43.patch
new file mode 100644
index 000000000000..3c65fda3a72a
--- /dev/null
+++ b/dev-util/skelgen/files/skelgen-1.2-gcc43.patch
@@ -0,0 +1,10 @@
+--- template.cpp.orig 2000-12-23 00:00:04.000000000 -0500
++++ template.cpp 2008-12-31 15:52:51.000000000 -0500
+@@ -31,6 +31,7 @@
+ // --------------------------------------------------------------------------------------------------------------------------------
+
+ #include "skelgen.h"
++#include "string.h"
+
+ // --------------------------------------------------------------------------------------------------------------------------------
+
diff --git a/dev-util/skelgen/metadata.xml b/dev-util/skelgen/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/skelgen/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/skelgen/skelgen-1.2.ebuild b/dev-util/skelgen/skelgen-1.2.ebuild
new file mode 100644
index 000000000000..845020460e64
--- /dev/null
+++ b/dev-util/skelgen/skelgen-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A Skeleton Source File Generator"
+HOMEPAGE="http://www.fluidstudios.com/"
+SRC_URI="http://www.fluidstudios.com/pub/FluidStudios/Tools/Fluid_Studios_Skeleton_Source_File_Generator-${PV}.zip"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+S=${WORKDIR}/source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ # Makefile uses $STRIPPER to strip executable, so use true
+ # instead and let portage handle that.
+ emake \
+ COMPILER="$(tc-getCXX)" \
+ COMPILER_OPTIONS="-c ${CXXFLAGS}" \
+ LINKER="$(tc-getCXX) ${LDFLAGS}" \
+ STRIPPER="true"
+}
+
+src_install() {
+ dobin skelgen
+ dodoc readme.txt
+ dodoc macros/{common.macro,personal.macro,work.macro}
+ dodoc templates/{default.{cpp,h},fluid.{cpp,h},gpl.{c,h},skelgen.{cpp,h}}
+}