summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-15 13:11:46 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-15 14:28:02 -0700
commit8b306c0ed0101997bac84e50cb122e489c98d004 (patch)
tree8d4b46ffbb4d9bf100e083905ed0138c4200cb9b /dev-util/spirv-headers
parentapp-text/aspell: Drop vulnerable (diff)
downloadgentoo-8b306c0ed0101997bac84e50cb122e489c98d004.tar.gz
gentoo-8b306c0ed0101997bac84e50cb122e489c98d004.tar.bz2
gentoo-8b306c0ed0101997bac84e50cb122e489c98d004.zip
dev-util/spirv-headers: 9999 cleanup, cmake.eclass
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/spirv-headers')
-rw-r--r--dev-util/spirv-headers/spirv-headers-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-util/spirv-headers/spirv-headers-9999.ebuild b/dev-util/spirv-headers/spirv-headers-9999.ebuild
index 7a7e30be5d45..7da32106bb4b 100644
--- a/dev-util/spirv-headers/spirv-headers-9999.ebuild
+++ b/dev-util/spirv-headers/spirv-headers-9999.ebuild
@@ -1,14 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils git-r3
+MY_PN=SPIRV-Headers
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+ S="${WORKDIR}"/${MY_PN}-${PV}
+fi
DESCRIPTION="Machine-readable files for the SPIR-V Registry"
-HOMEPAGE="https://www.khronos.org/registry/spir-v/"
-EGIT_REPO_URI="https://github.com/KhronosGroup/SPIRV-Headers.git"
-SRC_URI=""
+HOMEPAGE="https://www.khronos.org/registry/spir-v/ https://github.com/KhronosGroup/SPIRV-Headers"
LICENSE="MIT"
SLOT="0"