summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-29 15:12:19 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-29 15:15:17 -0400
commitae5dc52c91c6085a54a3454e218a088dcfe39c95 (patch)
tree29f7bbce31ec8b5450cc0e2fa956d7c4198d6cc8 /dev-util/strace/strace-4.9.ebuild
parentdev-util/strace: skip flaky -k test #545812 (diff)
downloadgentoo-ae5dc52c91c6085a54a3454e218a088dcfe39c95.tar.gz
gentoo-ae5dc52c91c6085a54a3454e218a088dcfe39c95.tar.bz2
gentoo-ae5dc52c91c6085a54a3454e218a088dcfe39c95.zip
dev-util/strace: add USE=unwind to control libunwind usage
Diffstat (limited to 'dev-util/strace/strace-4.9.ebuild')
-rw-r--r--dev-util/strace/strace-4.9.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/strace/strace-4.9.ebuild b/dev-util/strace/strace-4.9.ebuild
index 287aa8b3dfb3..5fd2fd6c1a92 100644
--- a/dev-util/strace/strace-4.9.ebuild
+++ b/dev-util/strace/strace-4.9.ebuild
@@ -19,12 +19,14 @@ HOMEPAGE="http://sourceforge.net/projects/strace/"
LICENSE="BSD"
SLOT="0"
-IUSE="aio +perl static"
+IUSE="aio +perl static unwind"
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
# strace only uses the header from libaio to decode structs
-DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
sys-kernel/linux-headers"
-RDEPEND=""
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
@@ -40,6 +42,10 @@ src_prepare() {
export ac_cv_header_libaio_h=$(usex aio)
}
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
src_install() {
default
use perl || rm "${ED}"/usr/bin/strace-graph