summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-05-18 03:58:11 -0400
committerMike Frysinger <vapier@gentoo.org>2018-05-18 04:05:57 -0400
commita4020520a87cd2ea89fac60283a683084c51dec6 (patch)
tree6768a66474989b7a1eda101bbc1c987795fd0e96 /dev-util/strace/strace-9999.ebuild
parentdev-util/strace: sync static fix w/9999 ebuild and document it #653292 (diff)
downloadgentoo-a4020520a87cd2ea89fac60283a683084c51dec6.tar.gz
gentoo-a4020520a87cd2ea89fac60283a683084c51dec6.tar.bz2
gentoo-a4020520a87cd2ea89fac60283a683084c51dec6.zip
dev-util/strace: use --enable-mpers=check everywhere #649560
We don't want to require full multilib toolchains everywhere, so allow the mpers logic to fail at configure time. We'll still get a strace that handles native programs fine. This also fixes aarch64 builds where the toolchain has no support for multilib, and there are no plans to add it (i.e. armv7 with aarch64). Closes: https://bugs.gentoo.org/649560
Diffstat (limited to 'dev-util/strace/strace-9999.ebuild')
-rw-r--r--dev-util/strace/strace-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 9a46478721fc..f9e3966c500e 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -63,7 +63,10 @@ src_configure() {
export "${v}_FOR_BUILD=${!bv}"
done
- econf $(use_with unwind libunwind)
+ # Don't require mpers support on non-multilib systems. #649560
+ econf \
+ --enable-mpers=check \
+ $(use_with unwind libunwind)
}
src_test() {