summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2020-04-25 10:42:06 +0200
committerCédric Krier <cedk@gentoo.org>2020-04-25 10:45:02 +0200
commitcc043b93456831d8f127966cc04c71e7ab6f9bdb (patch)
treebe63b79b24dc631bc63a7981f341d7009f2c5b02 /dev-util/stripe-mock/stripe-mock-0.88.0.ebuild
parentdev-python/python-stdnum: Version bumps (diff)
downloadgentoo-cc043b93456831d8f127966cc04c71e7ab6f9bdb.tar.gz
gentoo-cc043b93456831d8f127966cc04c71e7ab6f9bdb.tar.bz2
gentoo-cc043b93456831d8f127966cc04c71e7ab6f9bdb.zip
dev-util/stripe-mock: Version bumps
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.88.0.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.88.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.88.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.88.0.ebuild
new file mode 100644
index 000000000000..10557ae0ccc1
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.88.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D%/}$(get_golibdir_gopath)" || die
+}