summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-16 08:35:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-16 08:49:03 +0100
commit59f09d6fc40edfdb4a55d009919032d45aa9e473 (patch)
treea74264b804bd245a298fd0b0bc202481e148d36f /dev-util/stripe-mock
parentkde-apps/incidenceeditor: Punt bogus dep (diff)
downloadgentoo-59f09d6fc40edfdb4a55d009919032d45aa9e473.tar.gz
gentoo-59f09d6fc40edfdb4a55d009919032d45aa9e473.tar.bz2
gentoo-59f09d6fc40edfdb4a55d009919032d45aa9e473.zip
dev-util/stripe-mock: Bump to 0.115.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.115.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index cbf3480c0261..df2ab9772de9 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,2 +1,3 @@
DIST stripe-mock-0.113.0.tar.gz 628049 BLAKE2B 5886bc5884bac74502014e1ad59bcc16f1c58f373142c9aca9129b7c8c70556bcfda23576f2c70d71fd9a99bed00f0f95a36e26e95cef58aebf9a37a21e42bbd SHA512 1a3687685a5c48de89946a4949ee4da367585b5adecf6e9d002493f8ab23b1eb8e38e87ec0b60d6157ddcbd8601ef5c1fef5d279a98e80eb34e0bd529f798185
DIST stripe-mock-0.114.0.tar.gz 631280 BLAKE2B 6b5fc4b160363eaacda7d8fcc590c9812c05d8fa3bd305e52fd70aa54205620fa46bd7ae00044ad618ad03dc36bb318be27b311eeb9a5c77534dedc93a9d67c0 SHA512 e1df4318d34e5213eecb36b43ccfce327cbdf75bd9f786e8c5ff3cc793ebf3ecb376e5c24b41966d76874c1df80b543707ea2a4a857baf70a32fb7dac7d06066
+DIST stripe-mock-0.115.0.tar.gz 635087 BLAKE2B 7b2b9c9a1cfc5d3ba83b5699f07226bbcb020d7bc63d4f0e56d97092592254e436c459757c35c4dd9826ff231400394a57d87faef8086de9a60f9439ab156ad3 SHA512 025612d3e7870e1ecbeb8939d4df3291b354fea8ac1fda72074bdfc9c2de1d77329c8154858176469e86739aad4d43c7a43c0f379a5eccec4b5eab035c0b6832
diff --git a/dev-util/stripe-mock/stripe-mock-0.115.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.115.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.115.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}