summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-23 15:36:34 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-23 16:18:08 +0200
commit3988c3428a651d4427159207ae0e535da1196ac7 (patch)
tree08514dff8f4911f36c14d69ad7bbba4b35d38306 /dev-util/sysdig
parentdev-python/libvirt-python: x86 stable (bug #629462) (diff)
downloadgentoo-3988c3428a651d4427159207ae0e535da1196ac7.tar.gz
gentoo-3988c3428a651d4427159207ae0e535da1196ac7.tar.bz2
gentoo-3988c3428a651d4427159207ae0e535da1196ac7.zip
dev-util/sysdig: Bump to 0.18.0
Diffstat (limited to 'dev-util/sysdig')
-rw-r--r--dev-util/sysdig/Manifest1
-rw-r--r--dev-util/sysdig/sysdig-0.18.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-util/sysdig/Manifest b/dev-util/sysdig/Manifest
index cab3f72bbc0c..b56888065bd2 100644
--- a/dev-util/sysdig/Manifest
+++ b/dev-util/sysdig/Manifest
@@ -1 +1,2 @@
DIST sysdig-0.17.0.tar.gz 718719 SHA256 f009acc32f2b15fcb0d2267bde6f6de9b3445179003c979ba61a8836abdb78f9 SHA512 476e130151d1a8e9e782f074c45448becbef10397c0040e33febaf89c73f22c1716ebeeb2683f489a74c83f5d67174c9f21bb05d4327f35fb03ca1b9822889bc WHIRLPOOL a8f3e0aa45e00d9e6b02e0c26f3ec2f91cbf4d9a6caf955684617e2a1e7c9c0b92c0bdda3b2c254129008ea42bd2386710ef391714e13631e0e7d62fe9226ed0
+DIST sysdig-0.18.0.tar.gz 739774 SHA256 9caab6b4ef4a6d9f9ded8f79b1fcbe34a918c61b6f3b5a15d803f0f25e73497a SHA512 51649bc965d54b0e4b6c17d3b8f6a9c1710300b371c556193f04f25c71acbc96da1bfb6c636f8afdd8544de39d7bb1db0bd8ecc39d18d6f1f238d9e7819f0265 WHIRLPOOL de150a7254428edf88fbe34226ebb1bc96270fbb942d70cc483cef7c04e7a31e43e8efd070b44d78991bdeabc88bfd90370f0cfa7fcb71b41b72c4fd005f4e8c
diff --git a/dev-util/sysdig/sysdig-0.18.0.ebuild b/dev-util/sysdig/sysdig-0.18.0.ebuild
new file mode 100644
index 000000000000..ebc9e98519ac
--- /dev/null
+++ b/dev-util/sysdig/sysdig-0.18.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+MODULES_OPTIONAL_USE=modules
+inherit linux-mod bash-completion-r1 cmake-utils
+
+DESCRIPTION="A system exploration and troubleshooting tool"
+HOMEPAGE="https://www.sysdig.org/"
+SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+modules"
+
+RDEPEND="
+ app-misc/jq:0=
+ dev-lang/luajit:2=
+ >=dev-libs/jsoncpp-0.6_pre:0=
+ dev-libs/libb64:0=
+ sys-libs/ncurses:0=
+ sys-libs/zlib:0=
+ dev-libs/openssl:0=
+ net-misc/curl:0="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/os-headers"
+
+# needed for the kernel module
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's:-ggdb::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ # libscap examples are not installed or really useful
+ -DBUILD_LIBSCAP_EXAMPLES=OFF
+
+ # unbundle the deps
+ -DUSE_BUNDLED_DEPS=OFF
+ )
+
+ cmake-utils_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${S}/driver:)"
+ BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
+ BUILD_TARGETS="all"
+
+ if use modules; then
+ cmake-utils_src_make configure_driver
+
+ cp "${BUILD_DIR}"/driver/Makefile.dkms driver/Makefile || die
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ linux-mod_src_install
+
+ # remove sources
+ rm -r "${ED%/}"/usr/src || die
+
+ # move bashcomp to the proper location
+ dobashcomp "${ED%/}"/usr/etc/bash_completion.d/sysdig || die
+ rm -r "${ED%/}"/usr/etc || die
+}