summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-11-07 23:07:52 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-11-07 23:07:52 +0000
commitaba6b82f56ee4e00781f4c22fcd5b6f86554215b (patch)
tree381e4c5b119ef876b9eb82cc81709c23a6f361cc /dev-util/systemtap
parentsys-apps/util-linux: stable 2.30.2 for ia64, bug #636626 (diff)
downloadgentoo-aba6b82f56ee4e00781f4c22fcd5b6f86554215b.tar.gz
gentoo-aba6b82f56ee4e00781f4c22fcd5b6f86554215b.tar.bz2
gentoo-aba6b82f56ee4e00781f4c22fcd5b6f86554215b.zip
dev-util/systemtap: tweak operand constraints for ia64, bug #510134
Reported-by: Émeric Maschino Closes: https://bugs.gentoo.org/510134 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-util/systemtap')
-rw-r--r--dev-util/systemtap/files/systemtap-3.1-ia64.patch23
-rw-r--r--dev-util/systemtap/systemtap-3.1-r1.ebuild2
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/systemtap/files/systemtap-3.1-ia64.patch b/dev-util/systemtap/files/systemtap-3.1-ia64.patch
new file mode 100644
index 000000000000..4750207a6fff
--- /dev/null
+++ b/dev-util/systemtap/files/systemtap-3.1-ia64.patch
@@ -0,0 +1,23 @@
+Workaround build failure on ia64
+
+Avoid 'o' constraint to allow gcc to select register operand.
+That way instruction selector can satisfy all constraints
+for PROBE2 macro.
+
+Reported-by: Émeric Maschino
+Bug: https://bugs.gentoo.org/510134
+diff --git a/cache.cxx b/cache.cxx
+index 3546b30..2710abf 100644
+--- a/cache.cxx
++++ b/cache.cxx
+@@ -8,2 +8,10 @@
+
++#ifdef __ia64__
++// Default is: nor
++// We disable 'o' because gcc fails to select register
++// constraint for second instruction in 'add_script_to_cache'
++// https://bugs.gentoo.org/510134
++# define STAP_SDT_ARG_CONSTRAINT nr
++#endif
++
+ #include "config.h"
diff --git a/dev-util/systemtap/systemtap-3.1-r1.ebuild b/dev-util/systemtap/systemtap-3.1-r1.ebuild
index cd13a9e21c2e..bfd2527d9547 100644
--- a/dev-util/systemtap/systemtap-3.1-r1.ebuild
+++ b/dev-util/systemtap/systemtap-3.1-r1.ebuild
@@ -33,6 +33,8 @@ ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) -
DOCS="AUTHORS HACKING NEWS README"
+PATCHES=("${FILESDIR}"/${PN}-3.1-ia64.patch)
+
pkg_setup() {
linux-info_pkg_setup
python-single-r1_pkg_setup