summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-07-19 19:03:35 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-07-19 19:03:57 -0700
commit40cbcbd9b3cacd2d90576080d9a2d806320f71d7 (patch)
tree3ac2ecc4374137e3af0065148b8e45402c76dd3e /dev-util/trace-cmd/files
parentapp-misc/evemu: Added python3_6 to PYTHON_COMPAT (diff)
downloadgentoo-40cbcbd9b3cacd2d90576080d9a2d806320f71d7.tar.gz
gentoo-40cbcbd9b3cacd2d90576080d9a2d806320f71d7.tar.bz2
gentoo-40cbcbd9b3cacd2d90576080d9a2d806320f71d7.zip
dev-util/trace-cmd: Revbump, soname fix and install missing headers
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/trace-cmd/files')
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.8-makefile.patch48
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.8-soname.patch6
2 files changed, 51 insertions, 3 deletions
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.8-makefile.patch b/dev-util/trace-cmd/files/trace-cmd-2.8-makefile.patch
new file mode 100644
index 000000000000..f95ffc3b18c3
--- /dev/null
+++ b/dev-util/trace-cmd/files/trace-cmd-2.8-makefile.patch
@@ -0,0 +1,48 @@
+diff --git a/Makefile b/Makefile
+index ad74a96..3bab851 100644
+--- a/Makefile
++++ b/Makefile
+@@ -64,7 +64,7 @@ python_dir = $(HOME)/.trace-cmd/python
+ var_dir = $(HOME)/.trace-cmd/
+ else
+ plugin_dir = $(libdir)/trace-cmd/plugins
+-python_dir = $(libdir)/trace-cmd/python
++python_dir ?= $(libdir)/trace-cmd/python
+ PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
+ PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"
+ PLUGIN_DIR_SQ = '$(subst ','\'',$(PLUGIN_DIR))'
+@@ -136,8 +136,13 @@ export NO_PYTHON
+ test-build = $(if $(shell sh -c 'echo "$(1)" | \
+ $(CC) -o /dev/null -c -x c - > /dev/null 2>&1 && echo y'), $2)
+
++ifndef NO_UDIS86
+ # have udis86 disassembler library?
+-udis86-flags := $(call test-build,\#include <udis86.h>,-DHAVE_UDIS86 -ludis86)
++udis86-flags := -DHAVE_UDIS86
++udis86-ldflags := -ludis86
++else
++udis86-flags := -UHAVE_UDIS86
++endif # NO_UDIS86
+
+ define BLK_TC_FLUSH_SOURCE
+ #include <linux/blktrace_api.h>
+@@ -237,6 +242,7 @@ endif
+ # Append required CFLAGS
+ override CFLAGS += $(INCLUDES) $(PLUGIN_DIR_SQ) $(VAR_DIR)
+ override CFLAGS += $(udis86-flags) $(blk-flags)
++override LDFLAGS += $(udis86-ldflags)
+
+ CMD_TARGETS = trace-cmd $(BUILD_PYTHON)
+
+@@ -339,8 +345,10 @@ install_gui: install_cmd gui
+ install_libs: libs
+ $(Q)$(call do_install,$(LIBTRACECMD_SHARED),$(libdir_SQ))
+ $(Q)$(call do_install,$(LIBTRACEEVENT_SHARED),$(libdir_SQ))
+- $(Q)$(call do_install,$(src)/include/traceevent/event-parse.h,$(includedir_SQ))
++ $(Q)$(call do_install,$(src)/include/traceevent/event-parse.h,$(includedir_SQ)/traceevent)
++ $(Q)$(call do_install,$(src)/include/traceevent/trace-seq.h,$(includedir_SQ)/traceevent)
+ $(Q)$(call do_install,$(src)/include/trace-cmd/trace-cmd.h,$(includedir_SQ))
++ $(Q)$(call do_install,$(src)/include/trace-cmd/trace-filter-hash.h,$(includedir_SQ))
+
+ doc:
+ $(MAKE) -C $(src)/Documentation all
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.8-soname.patch b/dev-util/trace-cmd/files/trace-cmd-2.8-soname.patch
index 523f2d44467e..b869080fb013 100644
--- a/dev-util/trace-cmd/files/trace-cmd-2.8-soname.patch
+++ b/dev-util/trace-cmd/files/trace-cmd-2.8-soname.patch
@@ -3,11 +3,11 @@ index 260023a..9eb127d 100644
--- a/scripts/utils.mk
+++ b/scripts/utils.mk
@@ -54,7 +54,7 @@ do_build_static_lib = \
-
+
do_compile_shared_library = \
($(print_shared_lib_compile) \
- $(CC) --shared $^ -o $@)
-+ $(CC) --shared $^ -Wl,-soname,$@ -o $@)
-
++ $(CC) --shared $^ -Wl,-soname,$(@F) -o $@)
+
do_compile_plugin_obj = \
($(print_plugin_obj_compile) \