summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-04-09 17:55:09 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-04-09 17:55:09 -0700
commit6790ee11d7e93abaac0b18e0d58e8949fba2cbb8 (patch)
tree1da703f9d4dd31d14980965c655b608c9d10b1c0 /dev-util/trace-cmd/files
parentdev-util/meson: arm64 stable (bug #682986) (diff)
downloadgentoo-6790ee11d7e93abaac0b18e0d58e8949fba2cbb8.tar.gz
gentoo-6790ee11d7e93abaac0b18e0d58e8949fba2cbb8.tar.bz2
gentoo-6790ee11d7e93abaac0b18e0d58e8949fba2cbb8.zip
dev-util/trace-cmd: Clean up how flags are passed to the build system
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/trace-cmd/files')
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.7-makefile.patch15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.7-makefile.patch b/dev-util/trace-cmd/files/trace-cmd-2.7-makefile.patch
index da1ca62e7c04..a9d7584dc625 100644
--- a/dev-util/trace-cmd/files/trace-cmd-2.7-makefile.patch
+++ b/dev-util/trace-cmd/files/trace-cmd-2.7-makefile.patch
@@ -1,7 +1,8 @@
-diff -ur trace-cmd-v2.7.orig/Makefile trace-cmd-v2.7/Makefile
---- trace-cmd-v2.7.orig/Makefile 2018-02-01 23:35:28.000000000 +0100
-+++ trace-cmd-v2.7/Makefile 2018-09-16 16:42:58.445655156 +0200
-@@ -63,7 +63,7 @@
+diff --git a/Makefile b/Makefile
+index a5d2c38..a99e5a4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -63,7 +63,7 @@ python_dir = $(HOME)/.trace-cmd/python
var_dir = $(HOME)/.trace-cmd/
else
plugin_dir = $(libdir)/trace-cmd/plugins
@@ -10,7 +11,7 @@ diff -ur trace-cmd-v2.7.orig/Makefile trace-cmd-v2.7/Makefile
PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"
PLUGIN_DIR_SQ = '$(subst ','\'',$(PLUGIN_DIR))'
-@@ -119,8 +119,11 @@
+@@ -119,8 +119,13 @@ endif # NO_PYTHON
test-build = $(if $(shell sh -c 'echo "$(1)" | \
$(CC) -o /dev/null -c -x c - > /dev/null 2>&1 && echo y'), $2)
@@ -19,11 +20,13 @@ diff -ur trace-cmd-v2.7.orig/Makefile trace-cmd-v2.7/Makefile
-udis86-flags := $(call test-build,\#include <udis86.h>,-DHAVE_UDIS86 -ludis86)
+udis86-flags := -DHAVE_UDIS86
+udis86-ldflags := -ludis86
++else
++udis86-flags := -UHAVE_UDIS86
+endif # NO_UDIS86
define BLK_TC_FLUSH_SOURCE
#include <linux/blktrace_api.h>
-@@ -276,6 +279,7 @@
+@@ -276,6 +281,7 @@ endif
# Append required CFLAGS
override CFLAGS += $(CONFIG_FLAGS) $(INCLUDES) $(PLUGIN_DIR_SQ) $(VAR_DIR)
override CFLAGS += $(udis86-flags) $(blk-flags)