summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-01-06 10:05:07 +0100
committerFabian Groffen <grobian@gentoo.org>2021-01-06 10:06:17 +0100
commit3bebc6f1c4a6a8dd9eda3849699f3fe208bca60c (patch)
tree20a9391254314dbd7f5a0903ec9a234cd4953caa /dev-util/uncrustify
parentmedia-sound/ardour: removed obsolete 6.3 (diff)
downloadgentoo-3bebc6f1c4a6a8dd9eda3849699f3fe208bca60c.tar.gz
gentoo-3bebc6f1c4a6a8dd9eda3849699f3fe208bca60c.tar.bz2
gentoo-3bebc6f1c4a6a8dd9eda3849699f3fe208bca60c.zip
dev-util/uncrustify: version bump, fix /usr/share/doc install path
Closes: https://bugs.gentoo.org/744301 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-util/uncrustify')
-rw-r--r--dev-util/uncrustify/Manifest1
-rw-r--r--dev-util/uncrustify/uncrustify-0.71.0.ebuild6
-rw-r--r--dev-util/uncrustify/uncrustify-0.72.0.ebuild27
3 files changed, 31 insertions, 3 deletions
diff --git a/dev-util/uncrustify/Manifest b/dev-util/uncrustify/Manifest
index ea9a2e1cd1a4..531e0ed53675 100644
--- a/dev-util/uncrustify/Manifest
+++ b/dev-util/uncrustify/Manifest
@@ -1 +1,2 @@
DIST uncrustify-0.71.0.tar.gz 1704631 BLAKE2B 3dc9122647e2c173a776c4ad24c93d7b88fdd00c6c4f3070e68fd7a272218335063d8563446a3c8e72ff68e41d00a265aca76682a8cea201a33230377d7e425a SHA512 220ecbebb1c1d6abadb96c339e4ca9b264a04fa08bc83e9b0fabba5fae425efd1911d175d18b635521614ec9c33aa389fadaeec62ebf28a5d71e595900a92181
+DIST uncrustify-0.72.0.tar.gz 1530850 BLAKE2B 59b3ff4b47fee1f2a303e237d46b5fb656041e4d397aa97862cc7aebb6a5e705d036889a7b492bbe4393537ff52cf78af46bbe513e71aef19fca1388e3ffa79b SHA512 bfcbdf0d8198e1dd91f1c8283441a56669610a84d55a17cdd504571da09b26fef026fd3f753acd9950e498f574e6771a206c72b76ffdea97747b7a4fdb481862
diff --git a/dev-util/uncrustify/uncrustify-0.71.0.ebuild b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
index f53b1ddfba62..2bafeb7b0aa1 100644
--- a/dev-util/uncrustify/uncrustify-0.71.0.ebuild
+++ b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ $PV == *9999* ]]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -12,7 +12,7 @@ else
S=${WORKDIR}/${PN}-${P}
fi
-inherit cmake-utils ${scm_eclass}
+inherit cmake ${scm_eclass}
PYTHON_COMPAT=( python3_{6,7,8} )
diff --git a/dev-util/uncrustify/uncrustify-0.72.0.ebuild b/dev-util/uncrustify/uncrustify-0.72.0.ebuild
new file mode 100644
index 000000000000..ac5b39c2423b
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.72.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake python-any-r1 ${scm_eclass}
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"