summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-09 22:34:57 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-09 22:35:52 -0500
commit7924ee799d9dc44458d0ae77046e4792d2e83313 (patch)
tree1c527332a7dc4cb87c572064b29b962a25d84ca6 /dev-util/unifdef
parentapp-emulation/reg: export -n GOCACHE (diff)
downloadgentoo-7924ee799d9dc44458d0ae77046e4792d2e83313.tar.gz
gentoo-7924ee799d9dc44458d0ae77046e4792d2e83313.tar.bz2
gentoo-7924ee799d9dc44458d0ae77046e4792d2e83313.zip
dev-util/unifdef: port to EAPI 7
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-util/unifdef')
-rw-r--r--dev-util/unifdef/unifdef-2.10.ebuild10
-rw-r--r--dev-util/unifdef/unifdef-2.11.ebuild8
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/unifdef/unifdef-2.10.ebuild b/dev-util/unifdef/unifdef-2.10.ebuild
index 038a1285cef0..7cafc8e46a09 100644
--- a/dev-util/unifdef/unifdef-2.10.ebuild
+++ b/dev-util/unifdef/unifdef-2.10.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
inherit toolchain-funcs
-DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
-HOMEPAGE="http://dotat.at/prog/unifdef/"
-SRC_URI="http://dotat.at/prog/unifdef/${P}.tar.gz"
+DESCRIPTION="Remove #ifdef'ed lines from a file while otherwise leaving the file alone"
+HOMEPAGE="https://dotat.at/prog/unifdef/"
+SRC_URI="https://dotat.at/prog/unifdef/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -17,4 +18,5 @@ DOCS=( README )
src_prepare() {
sed -i '/^prefix/s:=.*:=/usr:' Makefile || die
tc-export CC
+ default
}
diff --git a/dev-util/unifdef/unifdef-2.11.ebuild b/dev-util/unifdef/unifdef-2.11.ebuild
index cb5bb6583722..848ad49bbe59 100644
--- a/dev-util/unifdef/unifdef-2.11.ebuild
+++ b/dev-util/unifdef/unifdef-2.11.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
-HOMEPAGE="http://dotat.at/prog/unifdef/"
-SRC_URI="http://dotat.at/prog/unifdef/${P}.tar.gz"
+HOMEPAGE="https://dotat.at/prog/unifdef/"
+SRC_URI="https://dotat.at/prog/unifdef/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -17,4 +18,5 @@ DOCS=( README )
src_prepare() {
sed -i "/^prefix/s:=.*:=${EPREFIX}/usr:" Makefile || die
tc-export CC
+ default
}