summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-04-05 10:08:10 +0200
committerFabian Groffen <grobian@gentoo.org>2018-04-05 10:08:10 +0200
commit123f0d077921cf488309e0213ff979453cf2a981 (patch)
tree73410b1aaa5acf07ca3c2821c7bcf77aba5bec8d /dev-util/valgrind
parentsys-apps/iproute2: Drop obsolete sed script. (diff)
downloadgentoo-123f0d077921cf488309e0213ff979453cf2a981.tar.gz
gentoo-123f0d077921cf488309e0213ff979453cf2a981.tar.bz2
gentoo-123f0d077921cf488309e0213ff979453cf2a981.zip
dev-util/valgrind: fix linking on Solaris
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/valgrind-3.13.0-r2.ebuild11
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild9
2 files changed, 19 insertions, 1 deletions
diff --git a/dev-util/valgrind/valgrind-3.13.0-r2.ebuild b/dev-util/valgrind/valgrind-3.13.0-r2.ebuild
index f509e509703b..0ef938d860fd 100644
--- a/dev-util/valgrind/valgrind-3.13.0-r2.ebuild
+++ b/dev-util/valgrind/valgrind-3.13.0-r2.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
else
SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
- KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
fi
DEPEND="mpi? ( virtual/mpi )"
@@ -37,6 +37,15 @@ src_prepare() {
# Fix --xml-socket command line option (qt-creator), bug #641790
eapply "${FILESDIR}"/${P}-xml-socket.patch
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
# Allow users to test their own patches
eapply_user
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index 2b96d5f5150c..b7152e95dc5e 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -31,6 +31,15 @@ src_prepare() {
# Respect CFLAGS, LDFLAGS
eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
# Allow users to test their own patches
eapply_user