summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-25 21:17:31 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-25 21:17:31 -0400
commit6481782a4cc9edb88224b6e3771d8c25bb6f514a (patch)
tree6b229c654cbaaf11718c050333df670582368c4d /dev-util/vint
parentx11-drivers/xf86-video-r128: x86 stable (bug #669588) (diff)
downloadgentoo-6481782a4cc9edb88224b6e3771d8c25bb6f514a.tar.gz
gentoo-6481782a4cc9edb88224b6e3771d8c25bb6f514a.tar.bz2
gentoo-6481782a4cc9edb88224b6e3771d8c25bb6f514a.zip
dev-util/vint: drop dev-python/pytest-cov dep
Test coverage counting is spurious in the context of gentoo testing. We don't need that dep. Bug: https://bugs.gentoo.org/662034 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util/vint')
-rw-r--r--dev-util/vint/vint-0.3.19.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-util/vint/vint-0.3.19.ebuild b/dev-util/vint/vint-0.3.19.ebuild
index 1e5cc17ad27c..f4c45248021c 100644
--- a/dev-util/vint/vint-0.3.19.ebuild
+++ b/dev-util/vint/vint-0.3.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,13 +27,11 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? (
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
>=dev-python/pytest-3.3.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.5.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
)
"
python_test() {
- py.test -v || die "Test suite failed with ${EPYTHON}"
+ pytest -vv || die "Test suite failed with ${EPYTHON}"
}