summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-04-17 13:26:27 +0800
committerYixun Lan <dlan@gentoo.org>2017-04-17 13:28:33 +0800
commit139ca0caf8ce599896128b9a22777c310ad0d8de (patch)
tree729bddc7875c104bdfb75943fb7e76133ae5df53 /dev-util/vmtouch/vmtouch-1.3.0.ebuild
parentnet-analyzer/sflowtool: Version bump. (diff)
downloadgentoo-139ca0caf8ce599896128b9a22777c310ad0d8de.tar.gz
gentoo-139ca0caf8ce599896128b9a22777c310ad0d8de.tar.bz2
gentoo-139ca0caf8ce599896128b9a22777c310ad0d8de.zip
dev-util/vmtouch: version bump 1.3.0
Gentoo-Bug: 613648 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-util/vmtouch/vmtouch-1.3.0.ebuild')
-rw-r--r--dev-util/vmtouch/vmtouch-1.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/vmtouch/vmtouch-1.3.0.ebuild b/dev-util/vmtouch/vmtouch-1.3.0.ebuild
new file mode 100644
index 000000000000..e043a354abd7
--- /dev/null
+++ b/dev-util/vmtouch/vmtouch-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Virtual Memory Toucher, portable file system cache diagnostics and control"
+HOMEPAGE="http://hoytech.com/vmtouch/"
+SRC_URI="https://github.com/hoytech/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local my_prefix="${ED}/usr"
+ emake PREFIX="${my_prefix}" MANDIR="${my_prefix}/share/man/man8" install
+ dodoc CHANGES README.md TODO
+}