summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/wxglade
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/wxglade')
-rw-r--r--dev-util/wxglade/Manifest1
-rw-r--r--dev-util/wxglade/files/wxglade-0.6.3-wxversion.patch12
-rw-r--r--dev-util/wxglade/metadata.xml8
-rw-r--r--dev-util/wxglade/wxglade-0.6.3-r1.ebuild69
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/wxglade/Manifest b/dev-util/wxglade/Manifest
new file mode 100644
index 000000000000..12c0c87c58ab
--- /dev/null
+++ b/dev-util/wxglade/Manifest
@@ -0,0 +1 @@
+DIST wxGlade-0.6.3.tar.gz 595243 SHA256 28f0a15a8eb4d16039a1981bdcdc74bed12b595a4de8c11cf068b970fb80a68d SHA512 7cb8cb99f2a3d97c2aa43a6ad5cbb8c1b6aafff0e5d120fca1760acbb44d2c8fb3bf8a4d5b42055e1b4bef061bfdbe8eee884f4e087b9d6572874b5b818a61f9 WHIRLPOOL d7af96614f12216c74af0120012925284408b59eb46c2379de4b3080d5fcad73b1e369c01944505bfe271d238e6d32dae54ffa2b377a48adffa4ff62e905a6ba
diff --git a/dev-util/wxglade/files/wxglade-0.6.3-wxversion.patch b/dev-util/wxglade/files/wxglade-0.6.3-wxversion.patch
new file mode 100644
index 000000000000..319bb85c1663
--- /dev/null
+++ b/dev-util/wxglade/files/wxglade-0.6.3-wxversion.patch
@@ -0,0 +1,12 @@
+diff -Naur wxGlade-0.6.1-orig/main.py wxGlade-0.6.1/main.py
+--- wxGlade-0.6.1-orig/main.py 2007-10-25 01:03:22.000000000 -0600
++++ wxGlade-0.6.1/main.py 2007-12-04 09:36:20.000000000 -0600
+@@ -7,7 +7,7 @@
+ # THIS PROGRAM COMES WITH NO WARRANTY
+
+ import wxversion
+-wxversion.ensureMinimal("2.6")
++wxversion.select("2.8")
+
+ #from wxPython.wx import *
+ import wx
diff --git a/dev-util/wxglade/metadata.xml b/dev-util/wxglade/metadata.xml
new file mode 100644
index 000000000000..72b7c58382b4
--- /dev/null
+++ b/dev-util/wxglade/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <upstream>
+ <remote-id type="sourceforge">wxglade</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/wxglade/wxglade-0.6.3-r1.ebuild b/dev-util/wxglade/wxglade-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..54ec6b075558
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.6.3-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils multilib python
+
+MY_P="wxGlade-${PV}"
+
+DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="dev-python/wxpython:2.8"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wxversion.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodoc CHANGES.txt README.txt TODO.txt
+ newicon icons/icon.xpm wxglade.xpm || die "installing wxglade.xpm failed"
+ doman "${S}"/debian/wxglade.1 || die "installing man failed"
+ rm -rf "${S}"/debian
+ dohtml -r "${S}"/docs/* || die "installing docs failied"
+ rm -rf "${S}"/docs
+
+ python_copy_sources
+
+ installation() {
+ pydir=$(python_get_sitedir)/${PN}
+ insinto "${pydir}"
+ doins "${S}"/credits.txt || die "installing credits.txt failed"
+ doins -r ./* || die "installing failed"
+ dosym /usr/share/doc/${PF}/html "${pydir}"/docs || die "doc symlink failed"
+ fperms 775 "${pydir}"/wxglade.py
+ dosym "${pydir}"/wxglade.py /usr/bin/wxglade-$(python_get_version) \
+ || die "main symlink failed"
+ }
+ python_execute_function -s installation
+
+ python_generate_wrapper_scripts -E -f -q "${D}"usr/bin/wxglade
+
+ make_desktop_entry wxglade wxGlade wxglade "Development;GUIDesigner"
+}
+
+pkg_postinst() {
+ python_mod_optimize wxglade
+}
+
+pkg_postrm() {
+ python_mod_cleanup wxglade
+}