summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 23:26:51 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 23:35:08 +0200
commit4a5122b7739c209206c6aefbaaacf53db6fbb250 (patch)
treebeb12fd4705f5ba414956b971cbc8f747bfefb99 /dev-util/xdelta
parentdev-util/makepp: Drop old (EAPI 0) (diff)
downloadgentoo-4a5122b7739c209206c6aefbaaacf53db6fbb250.tar.gz
gentoo-4a5122b7739c209206c6aefbaaacf53db6fbb250.tar.bz2
gentoo-4a5122b7739c209206c6aefbaaacf53db6fbb250.zip
dev-util/xdelta: Bump old slot to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/xdelta')
-rw-r--r--dev-util/xdelta/xdelta-1.1.4-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-1.1.4-r2.ebuild b/dev-util/xdelta/xdelta-1.1.4-r2.ebuild
new file mode 100644
index 000000000000..008f5b44ef68
--- /dev/null
+++ b/dev-util/xdelta/xdelta-1.1.4-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Computes changes between binary or text files and creates deltas"
+HOMEPAGE="https://xdelta.googlecode.com/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}"/${P}-m4.patch
+ eapply "${FILESDIR}"/${P}-glib2.patch
+ eapply "${FILESDIR}"/${P}-pkgconfig.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ default
+}