summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/yacc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/yacc')
-rw-r--r--dev-util/yacc/Manifest1
-rw-r--r--dev-util/yacc/files/mkstemp.patch15
-rw-r--r--dev-util/yacc/files/yacc-1.9.1-CVE-2008-3196.patch33
-rw-r--r--dev-util/yacc/files/yacc-1.9.1-ia64.patch24
-rw-r--r--dev-util/yacc/metadata.xml7
-rw-r--r--dev-util/yacc/yacc-1.9.1-r4.ebuild62
-rw-r--r--dev-util/yacc/yacc-1.9.1-r5.ebuild63
7 files changed, 205 insertions, 0 deletions
diff --git a/dev-util/yacc/Manifest b/dev-util/yacc/Manifest
new file mode 100644
index 000000000000..279e44ad8ef2
--- /dev/null
+++ b/dev-util/yacc/Manifest
@@ -0,0 +1 @@
+DIST yacc-1.9.1.tar.Z 64805 SHA256 8a0f3faf78d0ada00eea5ffd1e141bb7a979d5d570a4c8a9a6ea57e5f3751477 SHA512 6adb51c5f07e8084a86688589f52d9eee0183fb4d77508e36621a6b0ba91a5c4195feb87db3401ec69560554f71f2f6984dec01266e41e0fd54fa72ef1780e80 WHIRLPOOL 91bcefbf56374559c83c40ff5c15303d6547c607aa0ab98eea2883dc78fd82d638d6638787eb89fa283cc19791bf9e1cc3041ecc435404b012d913ee04664560
diff --git a/dev-util/yacc/files/mkstemp.patch b/dev-util/yacc/files/mkstemp.patch
new file mode 100644
index 000000000000..f037e331fb5b
--- /dev/null
+++ b/dev-util/yacc/files/mkstemp.patch
@@ -0,0 +1,15 @@
+--- main.c.orig 2002-12-17 14:28:54.000000000 -0500
++++ main.c 2002-12-17 14:29:31.000000000 -0500
+@@ -264,9 +264,9 @@
+ text_file_name[len + 5] = 't';
+ union_file_name[len + 5] = 'u';
+
+- mktemp(action_file_name);
+- mktemp(text_file_name);
+- mktemp(union_file_name);
++ mkstemp(action_file_name);
++ mkstemp(text_file_name);
++ mkstemp(union_file_name);
+
+ len = strlen(file_prefix);
+
diff --git a/dev-util/yacc/files/yacc-1.9.1-CVE-2008-3196.patch b/dev-util/yacc/files/yacc-1.9.1-CVE-2008-3196.patch
new file mode 100644
index 000000000000..2fbb83cfc6b1
--- /dev/null
+++ b/dev-util/yacc/files/yacc-1.9.1-CVE-2008-3196.patch
@@ -0,0 +1,33 @@
+Tue Jul 8 15:06:50 2008 UTC by otto
+
+Fix an venerable bug: if we're reducing a rule that has an empty
+right hand side and the yacc stackpointer is pointing at the very
+end of the allocated stack, we end up accessing the stack out of
+bounds by the implicit $$ = $1 action. Detected by my new malloc,
+experienced by sturm@ on sparc64; ok deraadt@
+
+
+Index: yacc-1.9.1/skeleton.c
+===================================================================
+--- yacc-1.9.1.orig/skeleton.c
++++ yacc-1.9.1/skeleton.c
+@@ -18,6 +18,7 @@ char *banner[] =
+ "/*static char yysccsid[] = \"from: @(#)yaccpar 1.9 (Berkeley) 02/21/93\";*/",
+ "static char yyrcsid[] = \"$Id: yacc-1.9.1-CVE-2008-3196.patch,v 1.1 2008/10/04 18:57:18 rbu Exp $\";",
+ "#endif",
++ "#include <string.h>",
+ "#define YYBYACC 1",
+ "#define YYMAJOR 1",
+ "#define YYMINOR 9",
+@@ -226,7 +227,10 @@ char *body[] =
+ " YYPREFIX, yystate, yyn, yyrule[yyn]);",
+ "#endif",
+ " yym = yylen[yyn];",
+- " yyval = yyvsp[1-yym];",
++ " if (yym)",
++ " yyval = yyvsp[1-yym];",
++ " else",
++ " memset(&yyval, 0, sizeof yyval);",
+ " switch (yyn)",
+ " {",
+ 0
diff --git a/dev-util/yacc/files/yacc-1.9.1-ia64.patch b/dev-util/yacc/files/yacc-1.9.1-ia64.patch
new file mode 100644
index 000000000000..c10e88541287
--- /dev/null
+++ b/dev-util/yacc/files/yacc-1.9.1-ia64.patch
@@ -0,0 +1,24 @@
+--- byacc-1.9/defs.h.busted Sat May 6 21:10:56 2000
++++ byacc-1.9/defs.h Sat May 6 21:11:22 2000
+@@ -1,7 +1,8 @@
+ #include <assert.h>
+ #include <ctype.h>
+ #include <stdio.h>
+-
++#include <string.h>
++#include <stdlib.h>
+
+ /* machine-dependent definitions */
+ /* the following definitions are for the Tahoe */
+@@ -280,10 +281,3 @@
+ extern int errno;
+
+
+-/* system functions */
+-
+-extern void free();
+-extern char *calloc();
+-extern char *malloc();
+-extern char *realloc();
+-extern char *strcpy();
+
diff --git a/dev-util/yacc/metadata.xml b/dev-util/yacc/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/dev-util/yacc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/yacc/yacc-1.9.1-r4.ebuild b/dev-util/yacc/yacc-1.9.1-r4.ebuild
new file mode 100644
index 000000000000..448e2541336a
--- /dev/null
+++ b/dev-util/yacc/yacc-1.9.1-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Yacc: Yet Another Compiler-Compiler"
+HOMEPAGE="http://dinosaur.compilertools.net/#yacc"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${P}.tar.Z"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Use our CFLAGS
+ sed -i -e 's: -O : $(CFLAGS) :' Makefile || die 'sed failed'
+
+ # mkstemp patch from byacc ebuild
+ epatch "${FILESDIR}"/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch "${FILESDIR}"/${P}-ia64.patch
+
+ # avoid stack access error, bug 232005
+ epatch "${FILESDIR}"/${P}-CVE-2008-3196.patch
+}
+
+src_compile() {
+ make clean || die
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin yacc || die
+ doman yacc.1
+ dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
+}
+
+pkg_preinst() {
+ # bison installs a /usr/bin/yacc symlink ...
+ # we need to remove it to avoid triggering
+ # collision-protect errors #90089
+ if [[ -L ${ROOT}/usr/bin/yacc ]] ; then
+ rm -f "${ROOT}"/usr/bin/yacc
+ fi
+}
+
+pkg_postrm() {
+ # and if we uninstall yacc but keep bison,
+ # lets restore the /usr/bin/yacc symlink
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] && [[ -e ${ROOT}/usr/bin/yacc.bison ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}
diff --git a/dev-util/yacc/yacc-1.9.1-r5.ebuild b/dev-util/yacc/yacc-1.9.1-r5.ebuild
new file mode 100644
index 000000000000..fcee41a056c0
--- /dev/null
+++ b/dev-util/yacc/yacc-1.9.1-r5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Yacc: Yet Another Compiler-Compiler"
+HOMEPAGE="http://dinosaur.compilertools.net/#yacc"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${P}.tar.Z"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Use our CFLAGS and LDFLAGS
+ sed -i -e 's: -O : $(CFLAGS) $(LDFLAGS) :' Makefile || die 'sed failed'
+
+ # mkstemp patch from byacc ebuild
+ epatch "${FILESDIR}"/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch "${FILESDIR}"/${P}-ia64.patch
+
+ # avoid stack access error, bug 232005
+ epatch "${FILESDIR}"/${P}-CVE-2008-3196.patch
+}
+
+src_compile() {
+ emake clean || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin yacc || die
+ doman yacc.1
+ dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
+}
+
+pkg_preinst() {
+ # bison installs a /usr/bin/yacc symlink ...
+ # we need to remove it to avoid triggering
+ # collision-protect errors #90089
+ if [[ -L ${ROOT}/usr/bin/yacc ]] ; then
+ rm -f "${ROOT}"/usr/bin/yacc
+ fi
+}
+
+pkg_postrm() {
+ # and if we uninstall yacc but keep bison,
+ # lets restore the /usr/bin/yacc symlink
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] && [[ -e ${ROOT}/usr/bin/yacc.bison ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}