summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 11:43:56 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 12:18:09 +0200
commit0fc27cfeeb7b0431db4da300e2b81dfeec90fc0c (patch)
treeabe1e6ae858d6e4a64021bb131a7030772f76f2e /dev-util
parentnet-fs/tahoe-lafs: Allow newer twisted (diff)
downloadgentoo-0fc27cfeeb7b0431db4da300e2b81dfeec90fc0c.tar.gz
gentoo-0fc27cfeeb7b0431db4da300e2b81dfeec90fc0c.tar.bz2
gentoo-0fc27cfeeb7b0431db4da300e2b81dfeec90fc0c.zip
dev-util/google-perftools: Bump to 2.7
Closes: https://bugs.gentoo.org/586834 Closes: https://bugs.gentoo.org/662590 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.7.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 3b610add720a..9979b0356e53 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -2,3 +2,4 @@ DIST gperftools-2.0.tar.gz 1261243 BLAKE2B a37c62f6f3c27a29036955c37a58c480e5cc6
DIST gperftools-2.4.tar.gz 890402 BLAKE2B f4893d7c9bbd3a8dc5b4d8a25837039261fa32782e13653991002ab666d6e81de637932a8b46c66df219336adcc395a217a4ce32332e8e1558beeb140ea642f2 SHA512 77198c150ee26579adc8f190be0c4ba90a9e3854b006c3aa9252b5863b1fce317fd690c6aa0ed202c81f0bbcfbe2d5f8a182263e77b7fb4fbc6b3e8bfffc9fb0
DIST gperftools-2.6.2.tar.gz 911744 BLAKE2B e5798a2f0f2973f02bccabb2550a9df54319e505fc715795cd836ced631b29bfd8e6f8ddf3c7f6dceb0f166523bb0fa55564b1cbc896c8cd8cfd475263c07c39 SHA512 20c3460f806c6425d54e8d1020f15bc8940aacd7bf1367b03a116fb873bbd6c1e1fbb75df1d0ca341eaec813552fec394327175115ea8442a4b7a1ef17f0df2f
DIST gperftools-2.6.3.tar.gz 911813 BLAKE2B dae223927835f65b819836b25595df2943a0762ac3b6346e3d0186dab486cfa3e4eabc1f5a2ec43314f53ea96a68acb75991b76055591395bc52e78f655630d3 SHA512 6418c382760c8870ef42a535fcb65a623c1a9fd3ab58fcb7cfe2dd5048b2268b434427da36bc0c76beef2c28e13a6926d32d67084d8ca6675b78650a62de77a7
+DIST gperftools-2.7.tar.gz 916919 BLAKE2B c48882df45415110c1ec39298e84ec9384f6a82851d95e92435649d2b253b9fb8e29664b474e45881599abf3781731c47ead0b6c454c33be9a207a6a2401a97c SHA512 9aa39689bc18603123204f024ab6dc96099b70a3d304e31ef0cc1e9893cc77bd14ee6eb420e597d40e81e487a2a45e77cf1965873646d056fd4b7bee22a4b0bb
diff --git a/dev-util/google-perftools/google-perftools-2.7.ebuild b/dev-util/google-perftools/google-perftools-2.7.ebuild
new file mode 100644
index 000000000000..79113d00762c
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-2.7.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MY_P="gperftools-${PV}"
+
+inherit toolchain-funcs flag-o-matic autotools vcs-snapshot multilib-minimal
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="https://github.com/gperftools/gperftools"
+SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+# contains ASM code, with support for
+# freebsd x86/amd64
+# linux x86/amd64/ppc/ppc64/arm
+# OSX ppc/amd64
+# AIX ppc/ppc64
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+IUSE="largepages +debug minimal optimisememory test static-libs"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ MAKEOPTS+=" noinst_PROGRAMS= "
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+ use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf \
+ --docdir=${EPREFIX}/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug debugalloc) \
+ $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sandbox is enabled."
+ ewarn "See https://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ if ! use minimal && has x32 ${MULTILIB_ABIS}; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gperftools/heap-checker.h
+ /usr/include/gperftools/heap-profiler.h
+ /usr/include/gperftools/stacktrace.h
+ /usr/include/gperftools/profiler.h
+ )
+ fi
+
+ multilib-minimal_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ use static-libs || find "${D}" -name '*.la' -delete || die
+}