summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYmrDtnJu <YmrDtnJu@users.noreply.github.com>2018-06-16 20:36:52 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-06-18 13:38:53 +0200
commit11c6d80669d85985bb9f8aabd052c89a34a2c84f (patch)
tree65da89a05b71d08cfea1e08b9042a720a0658cb3 /dev-util
parentprofiles/prefix/darwin/macos/10.5/ppc/package.mask: unmask gcc (diff)
downloadgentoo-11c6d80669d85985bb9f8aabd052c89a34a2c84f.tar.gz
gentoo-11c6d80669d85985bb9f8aabd052c89a34a2c84f.tar.bz2
gentoo-11c6d80669d85985bb9f8aabd052c89a34a2c84f.zip
dev-util/strace: Add use flag for elfutils.
strace can use libdw to implement stack tracing support and will use it automatically if it is installed on the system. The commit makes this configurable. Closes: https://github.com/gentoo/gentoo/pull/8860
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/metadata.xml3
-rw-r--r--dev-util/strace/strace-4.23-r1.ebuild (renamed from dev-util/strace/strace-4.23.ebuild)12
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-util/strace/metadata.xml b/dev-util/strace/metadata.xml
index 869980f0195f..ed202ff2ec68 100644
--- a/dev-util/strace/metadata.xml
+++ b/dev-util/strace/metadata.xml
@@ -12,6 +12,9 @@
<flag name="unwind">
Enable stack backtraces (-k flag) via <pkg>sys-libs/libunwind</pkg>
</flag>
+ <flag name="elfutils">
+ Enable stack backtraces (-k flag) via <pkg>dev-libs/elfutils</pkg>
+ </flag>
</use>
<upstream>
<remote-id type="sourceforge">strace</remote-id>
diff --git a/dev-util/strace/strace-4.23.ebuild b/dev-util/strace/strace-4.23-r1.ebuild
index 216395c678c1..a16ee1f785c0 100644
--- a/dev-util/strace/strace-4.23.ebuild
+++ b/dev-util/strace/strace-4.23-r1.ebuild
@@ -18,9 +18,14 @@ HOMEPAGE="https://strace.io/"
LICENSE="BSD"
SLOT="0"
-IUSE="aio perl static unwind"
+IUSE="aio perl static unwind elfutils"
-LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
+REQUIRED_USE="?? ( unwind elfutils )"
+
+LIB_DEPEND="
+ unwind? ( sys-libs/libunwind[static-libs(+)] )
+ elfutils? ( dev-libs/elfutils[static-libs(+)] )
+"
# strace only uses the header from libaio to decode structs
DEPEND="
static? ( ${LIB_DEPEND} )
@@ -66,7 +71,8 @@ src_configure() {
# Don't require mpers support on non-multilib systems. #649560
econf \
--enable-mpers=check \
- $(use_with unwind libunwind)
+ $(use_with unwind libunwind) \
+ $(use_with elfutils libdw)
}
src_test() {