summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:09:51 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:19:31 -0400
commit1d72e268a56495f6834ae41eb28adf8acff52993 (patch)
treec33c132e54bce5c45e3d82b35d0681d505f8b24a /dev-util
parentdev-util/buildbot-grid-view: Version bump to 3.1.1 (diff)
downloadgentoo-1d72e268a56495f6834ae41eb28adf8acff52993.tar.gz
gentoo-1d72e268a56495f6834ae41eb28adf8acff52993.tar.bz2
gentoo-1d72e268a56495f6834ae41eb28adf8acff52993.zip
dev-util/buildbot-wsgi-dashboards: Version bump to 3.1.1
sync KEYWORDS among the pkgs. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.1.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 932ece96d932..294f7b869934 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -4,3 +4,4 @@ DIST buildbot-wsgi-dashboards-2.8.2.tar.gz 5566 BLAKE2B 487b816862366acae9e55c39
DIST buildbot-wsgi-dashboards-2.8.4.tar.gz 5588 BLAKE2B 3298edaebe2f9eb5e31f8298598e892d64d653648843e3c107710d4df3a24977bd3e77db06f7edecdf8d85bbbdeedfc66a75c6f3eef93ec8374d0df1973790dc SHA512 656f0626c8cad2c21d64ebc3eb4d6e1ac24a10909afc28819e54046be8e843a7383f3648a00a908cfddd9543767e1c3293825170d7c6c64c40a61bdcd55245bd
DIST buildbot-wsgi-dashboards-3.0.2.tar.gz 5581 BLAKE2B a122d97fe5837319a1185e944db963f215da2390861f87a1d00d9e22b29776e259495ece4ba0c0248483d4715d4cc5aca5011fefb50fe1268a58c64c9bc0733f SHA512 881d874b31a59c44448ec90784db9778424fe53eed19d75cd588e359f50bf59eea209226bb3bc95c94174a54b1d42166f66c0642ea550adfe4e9b9f7f44013f9
DIST buildbot-wsgi-dashboards-3.1.0.tar.gz 5581 BLAKE2B 0ab769016aac877dbd2a802d87cb8a2de4e0019a810b1a448ee261cae9f0e9efc4a6ff4a7ff4c28c348d82639c8c4eee9f53a87340fa53c2971d8f4e977b4708 SHA512 40c9e328262c42c3c36bf85022a534cabc568a47280d82921ef6b5badaefdc94082984e3c5acede26fb62f27a38783ec03257d7500cdb7241c10fac7bd45971c
+DIST buildbot-wsgi-dashboards-3.1.1.tar.gz 5583 BLAKE2B ba0462e70e29cc1e6cfcc6a461373bdc56c03dc0510e7498310e722e0a5c494311f6da081f1ccccd2641657a7025885211802ce38b13326bde2f0b2f403ee198 SHA512 3a4a4621ae2ecca9313d2c6c4c33566b3e2e58c0259caaf135935362139eb4c1536669251138408c76c136ffe4a93ba9cbca7fa08b7b07e46472b2606b24ab06
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.1.1.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.1.1.ebuild
new file mode 100644
index 000000000000..4ddd7898f765
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"