summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-03 21:04:22 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-03 21:04:46 +0100
commit309cf6b34558677bb60c5524c8f3a31e2f7fcf0c (patch)
tree53f2d31e7c78eb19e371c30a8220d6229975a6ca /dev-util
parentnet-analyzer/nagios-plugin-check_lm_sensors: remove old (diff)
downloadgentoo-309cf6b34558677bb60c5524c8f3a31e2f7fcf0c.tar.gz
gentoo-309cf6b34558677bb60c5524c8f3a31e2f7fcf0c.tar.bz2
gentoo-309cf6b34558677bb60c5524c8f3a31e2f7fcf0c.zip
dev-util/pkgdiff: new package
Closes: https://bugs.gentoo.org/656326 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgdiff/Manifest1
-rw-r--r--dev-util/pkgdiff/metadata.xml9
-rw-r--r--dev-util/pkgdiff/pkgdiff-1.7.2.ebuild31
-rw-r--r--dev-util/pkgdiff/pkgdiff-9999.ebuild33
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/pkgdiff/Manifest b/dev-util/pkgdiff/Manifest
new file mode 100644
index 000000000000..1fff2bd7d3be
--- /dev/null
+++ b/dev-util/pkgdiff/Manifest
@@ -0,0 +1 @@
+DIST pkgdiff-1.7.2.tar.gz 56592 BLAKE2B 6190a8c1e018766802e12234890629efb356680dee84afdea1f989bc91196edc5460c3af3cba5229116ddcafac81f728d1d4eb52f009f9dc5f711a7718f2b0a9 SHA512 2369488e9705280be9b326b07aa9ef0e211440921b9cce5c35560a14d1ad4ac0040eb54024a88a4a5f8f831208b43124c17a817a44840500b490c89bf877b904
diff --git a/dev-util/pkgdiff/metadata.xml b/dev-util/pkgdiff/metadata.xml
new file mode 100644
index 000000000000..eaf46a7bd996
--- /dev/null
+++ b/dev-util/pkgdiff/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>fordfrog@gentoo.org</email>
+ <description>Miroslav Šulc</description>
+</maintainer>
+<longdescription>A tool for visualizing changes in Linux software packages</longdescription>
+</pkgmetadata>
diff --git a/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild b/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild
new file mode 100644
index 000000000000..10a3971dd704
--- /dev/null
+++ b/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Package Changes Analyzer (pkgdiff)"
+HOMEPAGE="https://github.com/lvc/pkgdiff"
+SRC_URI="https://github.com/lvc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}
+ sys-apps/diffutils
+ app-text/wdiff
+ sys-apps/gawk
+ sys-devel/binutils
+"
+
+src_compile() {
+ :
+}
+
+PREFIX="/usr"
+
+src_install() {
+ mkdir -p "${D}${PREFIX}"
+ perl Makefile.pl -install --destdir "${D}" || die "install failed"
+}
diff --git a/dev-util/pkgdiff/pkgdiff-9999.ebuild b/dev-util/pkgdiff/pkgdiff-9999.ebuild
new file mode 100644
index 000000000000..f397a5715c48
--- /dev/null
+++ b/dev-util/pkgdiff/pkgdiff-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Package Changes Analyzer (pkgdiff)"
+HOMEPAGE="https://github.com/lvc/pkgdiff"
+EGIT_REPO_URI="https://github.com/lvc/${PN}.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}
+ sys-apps/diffutils
+ app-text/wdiff
+ sys-apps/gawk
+ sys-devel/binutils
+"
+
+src_compile() {
+ :
+}
+
+PREFIX="/usr"
+
+src_install() {
+ mkdir -p "${D}${PREFIX}"
+ perl Makefile.pl -install --destdir "${D}" || die "install failed"
+}