summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-24 23:32:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-24 23:59:33 +0100
commit30c33c07c94332463b72487288d5b02372e64190 (patch)
tree41b15f48025102df0727ae68a72008e1401b62ef /dev-util
parentnet-libs/signon-ui: Drop 0.15-r1 (diff)
downloadgentoo-30c33c07c94332463b72487288d5b02372e64190.tar.gz
gentoo-30c33c07c94332463b72487288d5b02372e64190.tar.bz2
gentoo-30c33c07c94332463b72487288d5b02372e64190.zip
dev-util/cmocka: Add USE examples, EAPI-7 bump
Bug: https://bugs.gentoo.org/675876 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmocka/cmocka-1.1.3.ebuild13
-rw-r--r--dev-util/cmocka/files/cmocka-1.1.3-examples.patch45
2 files changed, 52 insertions, 6 deletions
diff --git a/dev-util/cmocka/cmocka-1.1.3.ebuild b/dev-util/cmocka/cmocka-1.1.3.ebuild
index 4cdb5fbec971..8153e29cfdba 100644
--- a/dev-util/cmocka/cmocka-1.1.3.ebuild
+++ b/dev-util/cmocka/cmocka-1.1.3.ebuild
@@ -1,32 +1,33 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-multilib
-DESCRIPTION="A unit testing framework for C"
+DESCRIPTION="Unit testing framework for C"
HOMEPAGE="https://cmocka.org/"
SRC_URI="https://cmocka.org/files/1.1/${P}.tar.xz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc static-libs test"
+IUSE="doc examples static-libs test"
-DEPEND="
+BDEPEND="
doc? ( app-doc/doxygen[dot] )
"
-RDEPEND=""
DOCS=( AUTHORS ChangeLog README.md )
PATCHES=(
"${FILESDIR}/${P}-fix-doxygen.patch" # bug 671404
+ "${FILESDIR}/${P}-examples.patch"
)
multilib_src_configure() {
local mycmakeargs=(
+ -DWITH_EXAMPLES=$(usex examples)
-DWITH_STATIC_LIB=$(usex static-libs)
-DUNIT_TESTING=$(usex test)
$(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
diff --git a/dev-util/cmocka/files/cmocka-1.1.3-examples.patch b/dev-util/cmocka/files/cmocka-1.1.3-examples.patch
new file mode 100644
index 000000000000..3d5fcc8098f0
--- /dev/null
+++ b/dev-util/cmocka/files/cmocka-1.1.3-examples.patch
@@ -0,0 +1,45 @@
+From ee264da1aa222b354cee36184ab48c2072f62243 Mon Sep 17 00:00:00 2001
+From: Andreas Schneider <asn@cryptomilk.org>
+Date: Wed, 23 Jan 2019 11:20:31 +0100
+Subject: [PATCH] cmake: Add WITH_EXAMPLES options
+
+This is turned on by default, but you can disable it, if you just
+package cmocka for an opterating system.
+
+Fixes #14
+
+Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
+---
+ CMakeLists.txt | 4 +++-
+ DefineOptions.cmake | 1 +
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7778039..702be97 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -60,7 +60,9 @@ if (UNIT_TESTING)
+ add_subdirectory(tests)
+ endif (UNIT_TESTING)
+
+-add_subdirectory(example)
++if (WITH_EXAMPLES)
++ add_subdirectory(example)
++endif ()
+
+ # pkg-config file
+ configure_file(cmocka.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/cmocka.pc)
+diff --git a/DefineOptions.cmake b/DefineOptions.cmake
+index 5bc1ef3..911ff1d 100644
+--- a/DefineOptions.cmake
++++ b/DefineOptions.cmake
+@@ -1,5 +1,6 @@
+ option(WITH_STATIC_LIB "Build with a static library" OFF)
+ option(WITH_CMOCKERY_SUPPORT "Install a cmockery header" OFF)
++option(WITH_EXAMPLES "Build examples" ON)
+ option(UNIT_TESTING "Build with unit testing" OFF)
+ option(PICKY_DEVELOPER "Build with picky developer flags" OFF)
+
+--
+2.18.1
+