summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-27 09:22:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-27 09:46:45 +0300
commit3aee4a342f0270b809e0c613c09762f8694c9b00 (patch)
tree86989bf56ce95f11c60995c9a1d49b67670fdc51 /dev-util
parentdev-util/shunit2: add myself as a maintainer (diff)
downloadgentoo-3aee4a342f0270b809e0c613c09762f8694c9b00.tar.gz
gentoo-3aee4a342f0270b809e0c613c09762f8694c9b00.tar.bz2
gentoo-3aee4a342f0270b809e0c613c09762f8694c9b00.zip
dev-util/shunit2: add 2.1.8
- Add test - Change LICENSE to Apache-2.0 - EAPI=8 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shunit2/Manifest1
-rw-r--r--dev-util/shunit2/shunit2-2.1.8.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/shunit2/Manifest b/dev-util/shunit2/Manifest
index 69f407331301..295f2a1406c1 100644
--- a/dev-util/shunit2/Manifest
+++ b/dev-util/shunit2/Manifest
@@ -1 +1,2 @@
DIST shunit2-2.1.6.tgz 61558 BLAKE2B 0568dbe6ff9234346d85925a7f27dc2c8e9003a3266ef0bf7c1bb5f73e06ce758c7ff82933899c9a99e37c189d2efdc111fe5132c69a4d80535dc4d14b7ec8d5 SHA512 c78cf349d72a9048e4932108a62b2d1873019b9b1909c3fb1bd7e873e7bb62df58c1941d916508dc60ef6ba0261a2bc6ee9e25d654eefdcce997682f2bc748d7
+DIST shunit2-2.1.8.tar.gz 52458 BLAKE2B 8b9a6f9d39636816369662a3fe3118901710bbb7b0fb5f3d367b3a7344b0c87d576982f0aedbd71a55ec57d4ad15eb0c57d1345bc6b68087d953373d6de2fb99 SHA512 15aaf28996c9fb5ee5419f63b50013a194a7416dea04eb34eae2481f05e0580bd2c6977ad002b421e2785e2024978fda869cad1ef4125857c2a5ea21bf44a06e
diff --git a/dev-util/shunit2/shunit2-2.1.8.ebuild b/dev-util/shunit2/shunit2-2.1.8.ebuild
new file mode 100644
index 000000000000..34e9c4ad0714
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts"
+HOMEPAGE="https://github.com/kward/shunit2"
+SRC_URI="https://github.com/kward/shunit2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-shells/dash
+ app-shells/ksh
+ app-shells/zsh
+ )
+"
+
+src_test() {
+ rm shunit2_macros_test.sh || die
+ ./test_runner || die
+}
+
+src_install() {
+ dobin shunit2
+
+ # For backwards compat to <=2.1.5
+ dosym -r /usr/bin/shunit2 /usr/share/shunit2/shunit2
+
+ dodoc -r examples
+ dodoc doc/*.txt
+}