summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-01-30 23:24:49 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-01-30 23:24:49 +0300
commit3e41d22f23a0b1bd8e83d29f982a8eab6c165666 (patch)
tree95fd5f2f04ce478ffe2314ddc3599cbb93fbbce7 /dev-util
parentsys-fs/udev: bump to 241-rc2 (diff)
downloadgentoo-3e41d22f23a0b1bd8e83d29f982a8eab6c165666.tar.gz
gentoo-3e41d22f23a0b1bd8e83d29f982a8eab6c165666.tar.bz2
gentoo-3e41d22f23a0b1bd8e83d29f982a8eab6c165666.zip
dev-util/pycharm-community: Version bump (v2018.3.4)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2018.3.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 9d7333c041e0..790e02e734c3 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -2,4 +2,5 @@ DIST pycharm-community-2018.2.4.tar.gz 260812419 BLAKE2B 2274d8af513535e4c5b3b69
DIST pycharm-community-2018.3.1.tar.gz 310702122 BLAKE2B c54153b9529bf03a09d92eb8b139da45bfb047cb1fdeacc9b64f17982edd237ed0633c391c15326ecaed7d9e599b3f87c0a16a2eb1302ceb37dfc1e0329693d0 SHA512 8d1f418bd97d8249481ad63fa699c141e498820698485b74c6f08674e4b0eee6054e9ad1e59260342fd615a5030ed932d1177ed8173ab9cf6026561c10fee9d8
DIST pycharm-community-2018.3.2.tar.gz 310664794 BLAKE2B 2dd7e59514909da3e319b1d8eb8b3e24e8dc7d67868ffea621b1c3273b6daa32459f09fb2d2e5b94d8044d9c2a0ea55d5940551bfd945e3ed8dabc200bcc2927 SHA512 613c1556dcf86f448cb496cf492ee76636dfef22cc4eb55f57ca1ed91a53f8a78da6455cc6f49becaa6250e136d786c92014e23a4333fbf0a6477a2f1e67a21c
DIST pycharm-community-2018.3.3.tar.gz 310740450 BLAKE2B 53552c228c81b17833d02a18f21838e768fdce3de8595a32fa832938208520306c1858d1e3ca509671e0412f2ec3b70acdf802a8af38816d91970f0c08b93147 SHA512 f1e774633718361fa623cb9810cd23be5da98f1bdc6cdfb01ef0980aa1163e0dea1e6c4ebbd1496ff903d81fec744f022a7c7854e29302c19d503541565dd1a0
+DIST pycharm-community-2018.3.4.tar.gz 310736836 BLAKE2B 2d43955b4d4299026c3fccd00c42e71b98c314d33857b1f81a84f365efde4b89d29b8c20826a3f89b6dc36fb293d867874edc75d68f5070516a27ccb68034cd2 SHA512 35b133b0db3b7fdbc4f08d0070de5aec8b3f170657c932e5c5c0af2e8c4be8b9e408558a0595794acd73e2ef5085295929b2a11013e6e72b852fead4ce572f60
DIST pycharm-community-2018.3.tar.gz 310642963 BLAKE2B b32f3c9a3c28bc1ee4658c1ef60cbbe2c4775b310512b3a7fd1b28839bf1c69a566198808b128d18cbbe2d987f61d80bcbcc590177b25d8e9c8fce5fb1754d49 SHA512 00121b4ee9daae92d5c389913f4dd9efcd634f9888b21f6bcae10a3a67cc4bc36a5012590e6836224168053521edf5ba848080f4fc1060df04dc4c58cfdd9fff
diff --git a/dev-util/pycharm-community/pycharm-community-2018.3.4.ebuild b/dev-util/pycharm-community/pycharm-community-2018.3.4.ebuild
new file mode 100644
index 000000000000..476b12dea206
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2018.3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}