summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:05:40 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:46:22 -0700
commit44999363626d89149d303b75e75cd56029906d5a (patch)
tree309bb97e9fe064feac3917aa2074075b84e79162 /dev-util
parentdev-util/buildbot-grid-view: Version bump (diff)
downloadgentoo-44999363626d89149d303b75e75cd56029906d5a.tar.gz
gentoo-44999363626d89149d303b75e75cd56029906d5a.tar.bz2
gentoo-44999363626d89149d303b75e75cd56029906d5a.zip
dev-util/buildbot-wsgi-dashboards: Version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 1648b09b499f..6beb9457fc44 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-wsgi-dashboards-2.7.0.tar.gz 5573 BLAKE2B e50576da2a86c3f63435c6ca721c0756e1bbe004e82a750d4f0a03799cde4b6c8db7a5199842ce46a835614ccfb588b4eca20035988f54c7d1b6dc9c43f31823 SHA512 018a103fd53f6c3fdca418a46d8576c6b1fd35c05b1cd2ef2dc2c8d30540fbf1528501369246c49d64cfc2d795bcb528fb672f0536a0239f64b87616c50c18c9
DIST buildbot-wsgi-dashboards-2.8.0.tar.gz 5576 BLAKE2B cad5d728ab7811b6e5f0750dd4e74ad25ac92c72a8e5f58beed0c19ba38de1599f5f5977c087acfbf2a138e41aa927ded54fd7ff9f1719de46560e814bb3320a SHA512 98217a351b0d441ab346d385b8b72333d100c33f40812f2c248a893a31e9ca157cc9e19048ed5a6e49283bdd9dd15ddbf5f16fd9e47ec5a63fedc959a93f1a33
+DIST buildbot-wsgi-dashboards-2.8.2.tar.gz 5566 BLAKE2B 487b816862366acae9e55c39cb440a21c8e5c438299c43e2d6fad049ff946ece5ab647390955fbbad403ad1d7c0a2707a7612129442dc398cc7210d831aa49ef SHA512 2b75a61331aa457b3f168e1955b8905f95d11008ab6bee611ac92488f988cb0cf73fbf92321e594ac0a6e5ae03b82dfa05daab5a0647ae636a96922c0f4e8eff
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.2.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.2.ebuild
new file mode 100644
index 000000000000..f124a0ef5c54
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"