summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-30 21:06:55 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-30 21:06:55 -0800
commit46abb5fa66fc184ac960a2677c964dc896967765 (patch)
tree7097020093d37a62d072c591833d910eebaa0132 /dev-util
parentapp-admin/mcollective: 2.11.4 stable with cleanup (diff)
downloadgentoo-46abb5fa66fc184ac960a2677c964dc896967765.tar.gz
gentoo-46abb5fa66fc184ac960a2677c964dc896967765.tar.bz2
gentoo-46abb5fa66fc184ac960a2677c964dc896967765.zip
dev-util/google-perftools: version bump to 2.6.2
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.6.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 10f07600b93f..28ebecf85774 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -3,4 +3,5 @@ DIST gperftools-2.0.tar.gz 1261243 SHA256 7de3dd91f018825b1e7d332af1edace15c6211
DIST gperftools-2.4.tar.gz 890402 SHA256 a73c2d066fb0d8e5a9102c0c17eadd8041f9b43b40b50faff54db01256772f6c SHA512 77198c150ee26579adc8f190be0c4ba90a9e3854b006c3aa9252b5863b1fce317fd690c6aa0ed202c81f0bbcfbe2d5f8a182263e77b7fb4fbc6b3e8bfffc9fb0 WHIRLPOOL 4b74a6074e1d0e0f6c5c3d8487a73045849237db93abcb5f4bb4aa7f40fcf9355d0cb1702335904ba6153ead62cb5a6df264d359bc1ce32fbb13fba4d2f2ddbc
DIST gperftools-2.5.tar.gz 895753 SHA256 0256331e67e8be12995b57183ec6affd071231f997bfcb5d5b050f86d4ad577e SHA512 974b86eadebe0437f4b7cf51de84afa315390cdcd2a88c8ccc8448b0b3e98c2241d89b4987b5fca1937102ae00a43802d9d06d7b11272e3dfeeaa23cf58ad68d WHIRLPOOL 4fc82910585107a2a879cae1b83afdcf98a39c3c7cbce3e8ba28b7b00ea1f638bb795213b7a6330bb311dd399bd7bcf34b3705cb8f75921ac1fd9ce3c0d1e8fd
DIST gperftools-2.6.1.tar.gz 907916 SHA256 3a51215bf0f0c1eedaef9cd377fe6b47dddafc3e5a66d292abb176e1ed36aab8 SHA512 49c1123ef8e297381e30fae6fc2391539ac5e1d3097b3f9f59c21853589152e248e92be0739bc50da6e5542f2638a9719b88f2d454221f463915d89e569776d2 WHIRLPOOL f93beba285703e199b27fd03e9c16732dcd9b625a16daad02c255392627dcf57b093a767bc645716b5f3395446c6181678c775b53f7d2dc151a398dad737a761
+DIST gperftools-2.6.2.tar.gz 911744 BLAKE2B e5798a2f0f2973f02bccabb2550a9df54319e505fc715795cd836ced631b29bfd8e6f8ddf3c7f6dceb0f166523bb0fa55564b1cbc896c8cd8cfd475263c07c39 SHA512 20c3460f806c6425d54e8d1020f15bc8940aacd7bf1367b03a116fb873bbd6c1e1fbb75df1d0ca341eaec813552fec394327175115ea8442a4b7a1ef17f0df2f
DIST gperftools-2.6.tar.gz 906841 SHA256 ff07a20a522fc729b899c542fedd3156fb1600973786542917675f7634b4905c SHA512 9fc32066304b76ad323e90ce2e7b437e7f1a5094b8d40a0e3df4d317fd57b4c048a19dacb7d148bd40557a080b0b82fe2da8ef32ae5511735ca7118e06b1ee38 WHIRLPOOL c91ffd09e9fd3202c17813d27370b144fa4140a6bd62b3e6c662557ac674c16575edcd50313d2cd342834a6ea5e799b96dca72ff600714486f9515bcc0c538c1
diff --git a/dev-util/google-perftools/google-perftools-2.6.2.ebuild b/dev-util/google-perftools/google-perftools-2.6.2.ebuild
new file mode 100644
index 000000000000..708d67991674
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-2.6.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="gperftools-${PV}"
+inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="https://github.com/gperftools/gperftools"
+SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+# contains ASM code, with support for
+# freebsd x86/amd64
+# linux x86/amd64/ppc/ppc64/arm
+# OSX ppc/amd64
+# AIX ppc/ppc64
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="largepages +debug minimal optimisememory test static-libs"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS="docs"
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ MAKEOPTS+=" noinst_PROGRAMS= "
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+ use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf \
+ --htmldir=${EPREFIX}/usr/share/doc/${PF}/html \
+ --docdir=${EPREFIX}/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug debugalloc) \
+ $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sandbox is enabled."
+ ewarn "See https://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ if ! use minimal && has x32 ${MULTILIB_ABIS}; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gperftools/heap-checker.h
+ /usr/include/gperftools/heap-profiler.h
+ /usr/include/gperftools/stacktrace.h
+ /usr/include/gperftools/profiler.h
+ )
+ fi
+
+ multilib-minimal_src_install
+}