summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-12-01 23:20:34 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-12-01 23:20:45 -0800
commit4befc9afad985df29fcce013b05cd0e1748539b1 (patch)
treee181a48319aadb87dca2a64b236e18c015c8c98a /dev-util
parentx11-wm/icewm: Removed old (diff)
downloadgentoo-4befc9afad985df29fcce013b05cd0e1748539b1.tar.gz
gentoo-4befc9afad985df29fcce013b05cd0e1748539b1.tar.bz2
gentoo-4befc9afad985df29fcce013b05cd0e1748539b1.zip
dev-util/bcc: revbump, symlink tools to system path (bug #741466)
This is much easier with eapi-dosym.eclass, so let's finally get around to adding this to the ebuild. Closes: https://bugs.gentoo.org/741466 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bcc/bcc-0.23.0-r1.ebuild (renamed from dev-util/bcc/bcc-0.23.0.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-util/bcc/bcc-0.23.0.ebuild b/dev-util/bcc/bcc-0.23.0-r1.ebuild
index ed3e78d5e3c5..c9b8d16482cd 100644
--- a/dev-util/bcc/bcc-0.23.0.ebuild
+++ b/dev-util/bcc/bcc-0.23.0-r1.ebuild
@@ -7,7 +7,7 @@ LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{7..10} )
LLVM_MAX_SLOT=13
-inherit cmake linux-info llvm lua-single python-r1
+inherit cmake eapi8-dosym linux-info llvm lua-single python-r1
DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
HOMEPAGE="https://iovisor.github.io/bcc/"
@@ -111,4 +111,11 @@ src_install() {
python_foreach_impl python_optimize
newenvd "${FILESDIR}"/60bcc.env 60bcc.env
+
+ local tool name
+ for tool in "${ED}"/usr/share/bcc/tools/*; do
+ [[ ! -x ${tool} && ! -L ${tool} || -d ${tool} ]] && continue
+ name=${tool##*/}
+ dosym8 -r "${tool#${ED}}" /usr/sbin/${name}
+ done
}