summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-11-17 19:14:00 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-11-17 19:14:08 +1100
commit4c0785fe0b8191b752315b3f26ea7657cb9b5a3e (patch)
treed4aee9a502be88ddadee378b114604b8194dca6d /dev-util
parentkde-misc/rsibreak: version bump 0.12.9 (diff)
downloadgentoo-4c0785fe0b8191b752315b3f26ea7657cb9b5a3e.tar.gz
gentoo-4c0785fe0b8191b752315b3f26ea7657cb9b5a3e.tar.bz2
gentoo-4c0785fe0b8191b752315b3f26ea7657cb9b5a3e.zip
dev-util/cmocka: version bump 1.1.3
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmocka/Manifest1
-rw-r--r--dev-util/cmocka/cmocka-1.1.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/cmocka/Manifest b/dev-util/cmocka/Manifest
index 075e38d43da0..26ad9c3f123d 100644
--- a/dev-util/cmocka/Manifest
+++ b/dev-util/cmocka/Manifest
@@ -1 +1,2 @@
DIST cmocka-1.1.1.tar.xz 85648 BLAKE2B de888cb0dace6ee598bbdf4521b909c7fd2e02702829793efd7bac5cebd581cfb5cc79015b39f33be0ad3af218575f47abf6b2b6a146dc5e21a491442fa557ff SHA512 801c4a3e1bb9047241b1cb5a90c1cbdee1b0aff5e3d0a84ec8b2dbaee79274618c24fbe5e9fedbf0b3ee18c6c98b55d93e135d037ac33ab872edc7665af41577
+DIST cmocka-1.1.3.tar.xz 78744 BLAKE2B 5043a496afab08837a73c2e0ff9c9b3c3880a2fd394a768b1f8b51d2fec517a5527e93b7e660f8dcc73af79aaf88e224f4e2869c7e31540f8e54c76481905ff6 SHA512 b1a2ce72234256d653eebf95f8744a34525b9027e1ecf6552e1620c83a4bdda8b5674b748cc5fd14abada1e374829e2e7f0bcab0b1c8d6c3b7d9b7ec474b6ed3
diff --git a/dev-util/cmocka/cmocka-1.1.3.ebuild b/dev-util/cmocka/cmocka-1.1.3.ebuild
new file mode 100644
index 000000000000..6ae39d5ba5d4
--- /dev/null
+++ b/dev-util/cmocka/cmocka-1.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A unit testing framework for C"
+HOMEPAGE="https://cmocka.org/"
+SRC_URI="https://cmocka.org/files/1.1/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs test"
+
+DEPEND="
+ doc? ( app-doc/doxygen[latex] )
+"
+RDEPEND=""
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DWITH_STATIC_LIB=$(usex static-libs)
+ -DUNIT_TESTING=$(usex test)
+ $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
+ || echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc; then
+ pushd doc || die
+ doxygen Doxyfile || die
+ rm -f html/*.md5 latex/*.md5 latex/Manifest man/man3/_* || die
+ dodoc -r html/
+ dodoc -r latex/
+ doman man/man3/*.3
+ popd || die
+ fi
+
+ cmake-utils_src_install
+}