summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:54:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:06 +0200
commit4e3f7a4533a05284ecab739f360b028048ca5481 (patch)
tree36bfee7d317d81e249eeca4e5572927bf00ccf8c /dev-util
parentdev-util/rosdep: Remove old (diff)
downloadgentoo-4e3f7a4533a05284ecab739f360b028048ca5481.tar.gz
gentoo-4e3f7a4533a05284ecab739f360b028048ca5481.tar.bz2
gentoo-4e3f7a4533a05284ecab739f360b028048ca5481.zip
dev-util/rosdep: bump to 0.19.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rosdep/Manifest1
-rw-r--r--dev-util/rosdep/rosdep-0.19.0.ebuild63
-rw-r--r--dev-util/rosdep/rosdep-9999.ebuild2
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-util/rosdep/Manifest b/dev-util/rosdep/Manifest
index 45c0ac838e21..b99141fd4d19 100644
--- a/dev-util/rosdep/Manifest
+++ b/dev-util/rosdep/Manifest
@@ -1 +1,2 @@
DIST rosdep-0.15.0.tar.gz 301659 BLAKE2B c7e5602e78e8f4892f16ef41d7423e653750def24f043c2519646b8c038bcb39b62d60323ef4e8a496a863bb74f51cdce7aebb1b5423120562a34c1988437510 SHA512 d9def23a4c01636a42dbccf99be96b9704eb96641da00db4305c63b18fa0f69de1ae402bcf7fff4030bc20097496086ff9168794d1e5cd44153cb3a84ba18509
+DIST rosdep-0.19.0.tar.gz 309029 BLAKE2B d4d9f607757c418f848a89987db6ff17a98719d0cacab49250abf45145a9f5b538d9442622ec3a8c3536061e82e624f25c9a7b777662b686167e2fdce88433ec SHA512 3e1d5829689646d583da2eaaf3b8bbddec3cb4ca3dc3941ee2697f6367510a4dcff11984fa1792a400f49132778d7869f0a8274e42bc8c04f2e326e6a663c494
diff --git a/dev-util/rosdep/rosdep-0.19.0.ebuild b/dev-util/rosdep/rosdep-0.19.0.ebuild
new file mode 100644
index 000000000000..87bf51cf6bb3
--- /dev/null
+++ b/dev-util/rosdep/rosdep-0.19.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tool for installing ROS system dependencies"
+HOMEPAGE="http://wiki.ros.org/rosdep"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/nose[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+}
+
+pkg_postrm() {
+ if [ "${ROOT:-/}" = "/" ] ; then
+ einfo "Removing rosdep default sources list."
+ rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
+ einfo "Initializing rosdep"
+ rosdep init
+ fi
+}
diff --git a/dev-util/rosdep/rosdep-9999.ebuild b/dev-util/rosdep/rosdep-9999.ebuild
index ae19fe69509a..87bf51cf6bb3 100644
--- a/dev-util/rosdep/rosdep-9999.ebuild
+++ b/dev-util/rosdep/rosdep-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then