summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-09-29 19:19:59 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-09-29 19:21:31 +0300
commit52be505267c2a9485045472a47990a8eaed6b1fd (patch)
tree0f4145a4255ff64c74dcaf7b3c34233ab3849b86 /dev-util
parentapp-emulation/rkt: rename rkt_stage1_kvm to rkt_stage1_kvm_lkvm (diff)
downloadgentoo-52be505267c2a9485045472a47990a8eaed6b1fd.tar.gz
gentoo-52be505267c2a9485045472a47990a8eaed6b1fd.tar.bz2
gentoo-52be505267c2a9485045472a47990a8eaed6b1fd.zip
dev-util/oprofile: fix bug 594178
Add gcc-6 love. Patch from upstream commits by Peter Levine plevine457/gmail.com. Package-Manager: portage-2.3.1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch30
-rw-r--r--dev-util/oprofile/oprofile-0.9.9-r1.ebuild3
-rw-r--r--dev-util/oprofile/oprofile-0.9.9-r2.ebuild1
-rw-r--r--dev-util/oprofile/oprofile-1.1.0-r1.ebuild7
4 files changed, 39 insertions, 2 deletions
diff --git a/dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch b/dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch
new file mode 100644
index 000000000000..ab3ca7c1b142
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch
@@ -0,0 +1,30 @@
+--- a/libop/op_alloc_counter.c
++++ b/libop/op_alloc_counter.c
+@@ -171,7 +171,7 @@
+ /* no counters then probably perfmon managing perfmon hw */
+ if (nr_counters <= 0) {
+ nr_counters = op_get_nr_counters(cpu_type);
+- unavailable_counters = (~0) << nr_counters;
++ unavailable_counters = (~0U) << nr_counters;
+ }
+
+ /* Check to see if we have enough physical counters to map events*/
+--- a/libutil++/op_bfd.cpp
++++ b/libutil++/op_bfd.cpp
+@@ -535,15 +535,13 @@
+ {
+ op_bfd_symbol const & sym = syms[sym_idx];
+
+- bool const verbose = cverb << (vbfd & vlevel1);
+-
+ if (anon_obj)
+ start = sym.vma();
+ else
+ start = sym.filepos();
+ end = start + sym.size();
+
+- if (!verbose)
++ if (!(cverb << (vbfd & vlevel1)))
+ return;
+
+ io_state state(cverb << (vbfd & vlevel1));
diff --git a/dev-util/oprofile/oprofile-0.9.9-r1.ebuild b/dev-util/oprofile/oprofile-0.9.9-r1.ebuild
index ee1c01837679..65ccf5a5eaca 100644
--- a/dev-util/oprofile/oprofile-0.9.9-r1.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -50,6 +50,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-gcc-4.9-non-ppc.patch"
epatch "${FILESDIR}/${P}-gcc-4.9-unused.patch"
epatch "${FILESDIR}/${PN}-1.0.0-athlon.patch"
+ epatch "${FILESDIR}/${PN}-1.1.0-gcc6.patch"
eautoreconf
}
diff --git a/dev-util/oprofile/oprofile-0.9.9-r2.ebuild b/dev-util/oprofile/oprofile-0.9.9-r2.ebuild
index 95dc5a56a974..2abc919ae232 100644
--- a/dev-util/oprofile/oprofile-0.9.9-r2.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.9-r2.ebuild
@@ -51,6 +51,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-gcc-4.9-non-ppc.patch"
epatch "${FILESDIR}/${P}-gcc-4.9-unused.patch"
epatch "${FILESDIR}/${PN}-1.0.0-athlon.patch"
+ epatch "${FILESDIR}/${PN}-1.1.0-gcc6.patch"
eautoreconf
}
diff --git a/dev-util/oprofile/oprofile-1.1.0-r1.ebuild b/dev-util/oprofile/oprofile-1.1.0-r1.ebuild
index 914d3652ebd6..6e83c7c0cddf 100644
--- a/dev-util/oprofile/oprofile-1.1.0-r1.ebuild
+++ b/dev-util/oprofile/oprofile-1.1.0-r1.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI="5"
-inherit java-pkg-opt-2 linux-info multilib user
+inherit eutils java-pkg-opt-2 linux-info multilib user
MY_P=${PN}-${PV/_/-}
DESCRIPTION="A transparent low-overhead system-wide profiler"
@@ -43,6 +43,11 @@ pkg_setup() {
use java && java-pkg_init
}
+src_prepare() {
+ # fix bug #594178
+ epatch "${FILESDIR}/${PN}-1.1.0-gcc6.patch"
+}
+
src_configure() {
econf \
--disable-werror \