summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-09-25 03:10:19 -0600
committerTim Harder <radhermit@gentoo.org>2019-09-25 03:11:12 -0600
commit67aa89e722915b40136ac3e1a6dca0ec1ea2f833 (patch)
treea4785bff9ffe5b8e26eee5856f13825e039a677f /dev-util
parentdev-db/mongodb: add missing dep, fixes #695442 (diff)
downloadgentoo-67aa89e722915b40136ac3e1a6dca0ec1ea2f833.tar.gz
gentoo-67aa89e722915b40136ac3e1a6dca0ec1ea2f833.tar.bz2
gentoo-67aa89e722915b40136ac3e1a6dca0ec1ea2f833.zip
dev-util/pkgcheck: add network use flag to pull in dev-python/requests
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgcheck/metadata.xml17
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild3
2 files changed, 12 insertions, 8 deletions
diff --git a/dev-util/pkgcheck/metadata.xml b/dev-util/pkgcheck/metadata.xml
index a43b6993fd17..81566c254d1c 100644
--- a/dev-util/pkgcheck/metadata.xml
+++ b/dev-util/pkgcheck/metadata.xml
@@ -1,11 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>radhermit@gentoo.org</email>
- <name>Tim Harder</name>
- </maintainer>
- <upstream>
- <remote-id type="github">pkgcore/pkgcheck</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="network">Enable support for network checks using <pkg>dev-python/requests</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">pkgcore/pkgcheck</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 773ee0cdb919..999998e6345b 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/pkgcore/pkgcheck"
LICENSE="BSD"
SLOT="0"
-IUSE="doc test"
+IUSE="doc network test"
RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
@@ -34,6 +34,7 @@ fi
RDEPEND+="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
+ network? ( dev-python/requests[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]