summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-21 15:22:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-21 15:22:15 +0100
commit7f0e99251be74d712e9a8bb8cc04341cfc04c887 (patch)
treeb791d10bf41cc9da2f78937104d37f2caf8039ab /dev-util
parentdev-lang/swi-prolog: bump development version (diff)
downloadgentoo-7f0e99251be74d712e9a8bb8cc04341cfc04c887.tar.gz
gentoo-7f0e99251be74d712e9a8bb8cc04341cfc04c887.tar.bz2
gentoo-7f0e99251be74d712e9a8bb8cc04341cfc04c887.zip
dev-util/kbuild: live ebuild improvements
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kbuild/kbuild-9999.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/dev-util/kbuild/kbuild-9999.ebuild b/dev-util/kbuild/kbuild-9999.ebuild
index 5df4852ffb28..ccbf4507612e 100644
--- a/dev-util/kbuild/kbuild-9999.ebuild
+++ b/dev-util/kbuild/kbuild-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-WANT_AUTOMAKE=1.9
-
-inherit autotools eutils subversion
+inherit autotools subversion
DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
HOMEPAGE="http://svn.netlabs.org/kbuild/wiki"
@@ -23,24 +21,29 @@ RDEPEND=""
S="${WORKDIR}/${MY_P/-src}"
src_prepare() {
- default
- rm -rf "${S}/kBuild/bin" || die
+ default
+ rm -rf "${S}/kBuild/bin" || die
+
+ # bootstrapping breaks because of missing po/Makefile.in.in
+ sed '/^AC_CONFIG_FILES/s@ po/Makefile\.in@@' \
+ -i src/kmk/configure.ac || die
- cd "${S}/src/kmk" || die
- eautoreconf
- cd "${S}/src/sed" || die
- eautoreconf
+ cd "${S}/src/kmk" || die
+ eautoreconf
+ cd "${S}/src/sed" || die
+ eautoreconf
}
src_compile() {
- kBuild/env.sh --full \
- make -f bootstrap.gmk AUTORECONF=true \
+ kBuild/env.sh --full \
+ emake -f bootstrap.gmk AUTORECONF=true \
|| die "bootstrap failed"
}
src_install() {
- kBuild/env.sh kmk \
+ kBuild/env.sh kmk \
NIX_INSTALL_DIR=/usr \
PATH_INS="${D}" \
- install || die "install failed"
+ install \
+ || die "install failed"
}