summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-29 21:45:20 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-29 21:47:07 +0100
commit8b23a01ee9c711bd6faec409c95c0b46f76abef2 (patch)
treef2f129a80aed2840421273bfae98167c50ad2cd7 /dev-util
parentdev-python/pbr: 3.1.1 stable arm arm64 and hppa (diff)
downloadgentoo-8b23a01ee9c711bd6faec409c95c0b46f76abef2.tar.gz
gentoo-8b23a01ee9c711bd6faec409c95c0b46f76abef2.tar.bz2
gentoo-8b23a01ee9c711bd6faec409c95c0b46f76abef2.zip
dev-util/radare2: use system-installed capstone, bug #592220
Reported-by: Anton Bolshakov Bug: https://bugs.gentoo.org/592220 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/radare2/metadata.xml3
-rw-r--r--dev-util/radare2/radare2-1.4.0-r1.ebuild45
-rw-r--r--dev-util/radare2/radare2-9999.ebuild6
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-util/radare2/metadata.xml b/dev-util/radare2/metadata.xml
index 248be000563e..43119efc7813 100644
--- a/dev-util/radare2/metadata.xml
+++ b/dev-util/radare2/metadata.xml
@@ -6,4 +6,7 @@
<name>Sergei Trofimovich</name>
<description>Primary Maintainer</description>
</maintainer>
+ <use>
+ <flag name='system-capstone'>Use <pkg>dev-libs/capstone</pkg> instead of bundled copy.</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-util/radare2/radare2-1.4.0-r1.ebuild b/dev-util/radare2/radare2-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..397bcc5a11f2
--- /dev/null
+++ b/dev-util/radare2/radare2-1.4.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Advanced command line hexadecimal editor and more"
+HOMEPAGE="http://www.radare.org"
+SRC_URI="http://cloud.radare.org/get/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl +system-capstone"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ system-capstone? ( dev-libs/capstone:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.9-nogit.patch
+)
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with system-capstone syscapstone)
+}
+
+src_install() {
+ # a workaround for unstable $(INSTALL) call, bug #574866
+ local d
+ for d in doc/*; do
+ if [[ -d $d ]]; then
+ rm -rfv "$d" || die "failed to delete '$d'"
+ fi
+ done
+
+ default
+}
diff --git a/dev-util/radare2/radare2-9999.ebuild b/dev-util/radare2/radare2-9999.ebuild
index cda7b0773b92..4c5adb60d123 100644
--- a/dev-util/radare2/radare2-9999.ebuild
+++ b/dev-util/radare2/radare2-9999.ebuild
@@ -14,10 +14,11 @@ EGIT_REPO_URI="https://github.com/radare/radare2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="ssl"
+IUSE="ssl +system-capstone"
RDEPEND="
ssl? ( dev-libs/openssl:0= )
+ system-capstone? ( dev-libs/capstone:0= )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -25,5 +26,6 @@ DEPEND="${RDEPEND}
src_configure() {
econf \
- $(use_with ssl openssl)
+ $(use_with ssl openssl) \
+ $(use_with system-capstone syscapstone)
}