summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTact Yoshida <otakuto.gentoo@gmail.com>2019-10-08 15:16:14 +0900
committerJoonas Niilola <juippis@gentoo.org>2019-10-10 16:56:57 +0300
commita14df27601cdb1c6a4c9121684d3f5721f3af1f9 (patch)
tree6911f3c34b047da084f1e9e243e1d9f4806a69f2 /dev-util
parentdev-db/sqlcl-bin: removed old (diff)
downloadgentoo-a14df27601cdb1c6a4c9121684d3f5721f3af1f9.tar.gz
gentoo-a14df27601cdb1c6a4c9121684d3f5721f3af1f9.tar.bz2
gentoo-a14df27601cdb1c6a4c9121684d3f5721f3af1f9.zip
dev-util/cutter: version bump to 1.9.0
Closes: https://bugs.gentoo.org/696680 Signed-off-by: Tact Yoshida <otakuto.gentoo@gmail.com> Package-Manager: Portage-2.3.66, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/13207 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cutter/Manifest1
-rw-r--r--dev-util/cutter/cutter-1.9.0.ebuild60
-rw-r--r--dev-util/cutter/files/cutter-1.9.0-python3-config.patch31
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-util/cutter/Manifest b/dev-util/cutter/Manifest
index ea7000ae2746..6772b6cd4d65 100644
--- a/dev-util/cutter/Manifest
+++ b/dev-util/cutter/Manifest
@@ -5,3 +5,4 @@ DIST cutter-1.7.4.tar.gz 1182307 BLAKE2B 7b80c99654c430c7d694b658c5757a0f75463f0
DIST cutter-1.7.tar.gz 1099734 BLAKE2B 200621a902fabee66ebb6e02cc0efb7a705320c6071db5ce64adee0717977a72056bb5ef3ea8f8cad05488c7f031da7c24bbfc2986bb780f111f0a3a5b7a5b0e SHA512 52eea3017ebe02dee4f4e2f7109486ef2b833359959f7058fff49b4462dbc551e6d25cf31da934c9dc8489dad68ad2a3ba8b12fa60789852d13e8d3cb225a1b8
DIST cutter-1.8.0.tar.gz 1431831 BLAKE2B 8fd54238acb83f5747679e520b40981fbffa4a19b8f96231fed1fee904cacee6cb02e5c483cfa8d00d0ced526cf6238e1a3a3a7353304fb603267fe7047822c2 SHA512 f88b581720ca969a1c34b671f31c8084bc588d5c7c3b1975d2012ac04abba953eaf87f28b72cc9ef608d14d8281aa92502efa965378fa89a9c174b049a9fca7e
DIST cutter-1.8.2.tar.gz 1527164 BLAKE2B 49ad9d208d77332c87acb2ed389d854ed8866bd561e89582266effd448bd3f1260f2e8d91ebc2fcbb7beb40aec39e460bc7a327021a4339db157af5a809cbc19 SHA512 16cb6a158882f17435e4c146b021a7ddb61a331efcb53e5a29e3598f399e71b59003473fa5a07cc0769148e67b02dbf955051bbb5ceb4df69b4cf1805b85f4cc
+DIST cutter-1.9.0.tar.gz 1548575 BLAKE2B 810b6d9f3b203f79711e38b26b60f545fd65f96e5b7d7638538c074ab7dbe83104d79b11f6b552d16e4a30236c5965ed377ad7d9c71cb8fce0a1d9d13076cd54 SHA512 f9b68469320e0e54562612cba21632f69dfe1e0bb1f21d05d7f0a083208e11f2e1a0ab338f8db43fb324aa8538b6f93d566eda13283d5b96ab1127c2d846b388
diff --git a/dev-util/cutter/cutter-1.9.0.ebuild b/dev-util/cutter/cutter-1.9.0.ebuild
new file mode 100644
index 000000000000..052885e5c900
--- /dev/null
+++ b/dev-util/cutter/cutter-1.9.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit qmake-utils xdg-utils python-single-r1
+
+DESCRIPTION="A Qt and C++ GUI for radare2 reverse engineering framework"
+HOMEPAGE="https://www.radare.org"
+SRC_URI="https://github.com/radareorg/cutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jupyter webengine"
+REQUIRED_USE="webengine? ( jupyter )
+ ${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-qt/qtcore-5.9.1:5
+ >=dev-qt/qtgui-5.9.1:5
+ >=dev-qt/qtsvg-5.9.1:5
+ >=dev-qt/qtwidgets-5.9.1:5
+ dev-qt/qtnetwork:5
+ >=dev-util/radare2-3.8.0
+ jupyter? ( dev-python/jupyter )
+ webengine? ( >=dev-qt/qtwebengine-5.9.1:5[widgets] )
+"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.0-python3-config.patch"
+)
+
+src_configure() {
+ local myqmakeargs=(
+ CUTTER_ENABLE_JUPYTER=$(usex jupyter true false)
+ CUTTER_ENABLE_QTWEBENGINE=$(usex webengine true false)
+ CUTTER_ENABLE_PYTHON=true
+ PREFIX=\'${EPREFIX}/usr\'
+ )
+
+ eqmake5 "${myqmakeargs[@]}" src
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/dev-util/cutter/files/cutter-1.9.0-python3-config.patch b/dev-util/cutter/files/cutter-1.9.0-python3-config.patch
new file mode 100644
index 000000000000..e2ab05564721
--- /dev/null
+++ b/dev-util/cutter/files/cutter-1.9.0-python3-config.patch
@@ -0,0 +1,31 @@
+diff -Naur cutter-1.8.0-orig/src/Cutter.pro cutter-1.8.0/src/Cutter.pro
+--- cutter-1.8.0-orig/src/Cutter.pro 2019-03-27 12:14:42.436446303 -0400
++++ cutter-1.8.0/src/Cutter.pro 2019-03-27 12:16:26.971448895 -0400
+@@ -118,10 +118,6 @@
+ # Libraries
+ include(lib_radare2.pri)
+
+-!win32 {
+- CONFIG += link_pkgconfig
+-}
+-
+ CUTTER_ENABLE_PYTHON {
+ win32 {
+ PYTHON_EXECUTABLE = $$system("where python", lines)
+@@ -140,10 +136,13 @@
+ LIBS += -F$$PYTHON_FRAMEWORK_DIR -framework Python
+ DEFINES += MACOS_PYTHON_FRAMEWORK_BUNDLED
+ } else {
+- !packagesExist(python3) {
+- error("ERROR: Python 3 could not be found. Make sure it is available to pkg-config.")
++ system(type python3-config) {
++ LIBS += $$system(python3-config --libs)
++ TMP = $$system(python3-config --includes)
++ INCLUDEPATH += $$replace(TMP, "-I", "")
++ } else {
++ error("ERROR: Python 3 could not be found. Make sure it is available to python3-config.")
+ }
+- PKGCONFIG += python3
+ }
+ }
+