summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-29 17:58:13 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-29 17:58:13 +0200
commita4bf38983b6aa2255e7d9eba2cdeba8b4abe3598 (patch)
treeb921f8119639e46c2e0e99747079e44895c0b48d /dev-util
parentsys-apps/fwupd: Removed old. (diff)
downloadgentoo-a4bf38983b6aa2255e7d9eba2cdeba8b4abe3598.tar.gz
gentoo-a4bf38983b6aa2255e7d9eba2cdeba8b4abe3598.tar.bz2
gentoo-a4bf38983b6aa2255e7d9eba2cdeba8b4abe3598.zip
dev-util/debootstrap: Version 1.0.104.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.104.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index 7d15bcedab87..0189dbef9618 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,4 +1,5 @@
DIST debootstrap_1.0.102.tar.gz 72977 BLAKE2B e5253a1317f586855cb33b56458ba7fec18d9ea330c999ad5d48830cc39311ad9a66b1f4fe7b8ce6bf0a7d0ccca50c00ebc07eb0aaf49ad9680ada46a66e863a SHA512 2ffb2f7d1ee19ea34c5d5f5a6951d6d5b4a298cea1438302cc0cc20cffeb1affa5774d7f77e332c5eb3f45698c9a10232415c89ad0aa34abec533768ea4a2dc2
DIST debootstrap_1.0.103.tar.gz 73167 BLAKE2B 063e27c1d58826bb7fec7879a5876df33b0da27cdbbdce3aa5ffecbcb70dba2814817e644725a132100cc7c7d182576bb2ba813f96bb4b289d06622d073da9d3 SHA512 4b43db32c46e5b69db9885494bc1f91197a40311c05196bf1c6e17d0a1f0519dbf61c8f5731c8627a708b8dfc8f3ba78e822a21879a5caf0d70046e3b7e60aa2
+DIST debootstrap_1.0.104.tar.gz 73264 BLAKE2B 28b4d1d1ad389dfb13f049529e5d14e1d8d82abf58b802ff25787e5c791c5d25aa2fd349f923b4e4d29bcbed78f2d32769189e110b6788acb67fb5499454dc52 SHA512 cfefa225a804e353195dedf5fbf0b005e7ac988f66c934927a312a32e8bbe9fd1083647fbafc5dbb3c7b55613887beb2c6296e3a5b8ed705b9ce18e850ee27a4
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.104.ebuild b/dev-util/debootstrap/debootstrap-1.0.104.ebuild
new file mode 100644
index 000000000000..93ffd5d2d1aa
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.104.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}