summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-06-17 06:51:50 +0200
committerHans de Graaff <graaff@gentoo.org>2022-06-17 06:51:50 +0200
commita66a9c2096ccdb1a33aace48e988a83b1f382285 (patch)
tree64291ac468cb45654e058974baedec96c6d35542 /dev-util
parentdev-java/tomcat-servlet-api: removed obsolete 10.0.20, 8.5.77, 8.5.78 & 9.0.62 (diff)
downloadgentoo-a66a9c2096ccdb1a33aace48e988a83b1f382285.tar.gz
gentoo-a66a9c2096ccdb1a33aace48e988a83b1f382285.tar.bz2
gentoo-a66a9c2096ccdb1a33aace48e988a83b1f382285.zip
dev-util/rbtools: add 3.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rbtools/Manifest1
-rw-r--r--dev-util/rbtools/rbtools-3.1.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/rbtools/Manifest b/dev-util/rbtools/Manifest
index 6b20ea1401dd..7f319f846e96 100644
--- a/dev-util/rbtools/Manifest
+++ b/dev-util/rbtools/Manifest
@@ -1,2 +1,3 @@
DIST RBTools-2.0.1.tar.gz 229394 BLAKE2B a3864c5a39854ffd8744cc562fb888aded06b86945b7b08bab1b172e557b80c0183352068722e6d530a7b0c2fae85f24ae1bbef9116538c5c31735ae5c47f313 SHA512 41ef3f6ad030e3551b76cce5358806442ddc78ad14cb3f2f5978d25858b44647fc80a8a98c84edc112d3e121748fa49aeca0ae24287c392d2f8d1d3b72df12ff
+DIST RBTools-3.1.1.tar.gz 317592 BLAKE2B c50e27cf67e2015904e2330208f0d13ec5a799d0820f6477a6701553140851a5d82de65fbf41d8b64bfcf0028a9baf27b710909d230e1798032a4e28f2b43935 SHA512 1a1aa51f8924b1fcdc100c0337c66870284b8c3c91cb756d231509111e4b9ae233ccae1245251e826dc23c699553f5d3441e4b9ef2b80f32d4ce8876dfa43819
DIST RBTools-3.1.tar.gz 317015 BLAKE2B dccabc93af3a8095f5e166f9e3a31cce52155876cb38675b3dd43b6556024bb9b4ed66291e495ab42b41b09934f136f4eeca7a185fc0fbb2aa2d03e1ef12d656 SHA512 2568aa905dfd119e0b66213e3ae9c8edad5a3337df00228b955006cc85e90c1492e1dc4cccc2695b53f5879103c5d4ee8dba6262112c8781e452dea7633d2c0b
diff --git a/dev-util/rbtools/rbtools-3.1.1.ebuild b/dev-util/rbtools/rbtools-3.1.1.ebuild
new file mode 100644
index 000000000000..2d330d85b678
--- /dev/null
+++ b/dev-util/rbtools/rbtools-3.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+MY_PN="RBTools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command line tools for use with Review Board"
+HOMEPAGE="https://www.reviewboard.org/"
+SRC_URI="https://downloads.reviewboard.org/releases/${MY_PN}/$(ver_cut 1-2)/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/pydiffx-1.0.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/texttable[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/kgb[${PYTHON_USEDEP}] )
+"
+
+DOCS=( AUTHORS NEWS README.md )
+
+S=${WORKDIR}/${MY_P}
+
+distutils_enable_tests nose
+
+src_prepare() {
+ default
+
+ # Avoid tests requiring unpackaged test data
+ rm -f rbtools/clients/tests/test_scanning.py || die
+
+ # Avoid repository specific tests to avoid dependencies on them
+ rm -f rbtools/clients/tests/test_{cvs,git,mercurial,svn}.py || die
+
+ # Fix test that appears to expect case-insentive comparison
+ sed -i -e 's/TEST CONTENT/Test content/' rbtools/utils/tests/test_console.py || die
+}
+
+python_test() {
+ distutils_install_for_testing
+ distutils-r1_python_test
+}