summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-05-30 21:16:54 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-05-30 21:16:54 -0700
commita7181fdca50e66f58ab6bb09d5d8bec30719a086 (patch)
treecb6a6daa80909c25fc0b5fb70bb069a55d628f79 /dev-util
parentdev-util/github-cli: fix PR#16024 issues (diff)
downloadgentoo-a7181fdca50e66f58ab6bb09d5d8bec30719a086.tar.gz
gentoo-a7181fdca50e66f58ab6bb09d5d8bec30719a086.tar.bz2
gentoo-a7181fdca50e66f58ab6bb09d5d8bec30719a086.zip
dev-util/github-cli: sync live ebuild
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/github-cli/github-cli-9999.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/dev-util/github-cli/github-cli-9999.ebuild b/dev-util/github-cli/github-cli-9999.ebuild
index 0cdc3f07d7d5..9da2da770a1f 100644
--- a/dev-util/github-cli/github-cli-9999.ebuild
+++ b/dev-util/github-cli/github-cli-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit go-module
+inherit bash-completion-r1 go-module
DESCRIPTION="GitHub CLI"
HOMEPAGE="https://github.com/cli/cli"
@@ -277,6 +277,10 @@ BDEPEND=">=dev-lang/go-1.13"
unset GOBIN GOPATH GOCODE
+PATCHES=(
+ "${FILESDIR}/cli-0.9.0-manpage-build-gen-docs.patch"
+)
+
src_unpack() {
if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
@@ -290,10 +294,24 @@ src_compile() {
[[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
# Golang LDFLAGS are not the same as GCC/Binutils LDFLAGS
unset LDFLAGS
- emake
+
+ emake bin/gh # default target
+
+ einfo "Building manpage"
+ emake manpages
+
+ einfo "Building completion"
+ bin/gh completion -s bash > gh.bash-completion || die
+ bin/gh completion -s zsh > gh.zsh-completion || die
}
src_install() {
dobin bin/gh
dodoc README.md
+
+ doman share/man/man?/gh*.?
+
+ newbashcomp gh.bash-completion gh
+ insinto /usr/share/zsh/site-functions
+ newins gh.zsh-completion _gh
}